aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-09-17 11:15:58 +0200
committerFilip Kobierski <fkobi@pm.me>2024-09-17 11:15:58 +0200
commit1f0837709d218f2345627412b727c3d4bfdddaec (patch)
treefc6ec7fe6d58fd5bebed7f301d8b63e599d16ec1 /net-p2p
parentdev-util/trivy: 0.55.1-r1 fix licenses (diff)
downloadguru-1f0837709d218f2345627412b727c3d4bfdddaec.tar.gz
guru-1f0837709d218f2345627412b727c3d4bfdddaec.tar.bz2
guru-1f0837709d218f2345627412b727c3d4bfdddaec.zip
net-p2p/monero: drop 0.18.3.{1.3-r1}
Signed-off-by: Filip Kobierski <fkobi@pm.me>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero/Manifest1
-rw-r--r--net-p2p/monero/monero-0.18.3.1.ebuild122
-rw-r--r--net-p2p/monero/monero-0.18.3.3-r1.ebuild122
3 files changed, 0 insertions, 245 deletions
diff --git a/net-p2p/monero/Manifest b/net-p2p/monero/Manifest
index 358ba01bd..005d2e4f1 100644
--- a/net-p2p/monero/Manifest
+++ b/net-p2p/monero/Manifest
@@ -1,4 +1,3 @@
DIST monero-0.17.3.2.tar.gz 10685156 BLAKE2B f313ec0e5e224797448a43ad46d4e990174eec6cdceec6dc9a25d62f014a775172e103d05a33558404bd84a8443ba6ada0c27f81a3a83fe630d16cbad97602f5 SHA512 2d34e0525b2ca1d7bddb8ea51776b49fec4fb866a1c1239c347460ed3369af2f430be32da45666f16c369cebef099f285971c0e806d75d60354f195c5f93891d
-DIST monero-0.18.3.1.tar.gz 14005197 BLAKE2B 169d876caf94090894c9a2bd9d07b71e46411971b06da0f51fc57f01396de4f5f770062e08cbebf702b6b49dbcd47923675d2375795969f5673bf2091a7da742 SHA512 b29d25043d50fa30459e59e0c82627cc3dc4a7e2e28a727a353915a32cf5e70e36f548bda152dee13329cb2d09a978ff45c2121f8bf7acc8966957a53e772f03
DIST monero-0.18.3.3.tar.gz 14028018 BLAKE2B 07c3272175fb05645a2f5f7ce6cef4d65054ba1d80994c4dc8445ec4df13aebe2b268d5b4be49db0cdd35dcdce1bbd33874111e21503839d63fae70ea30b0dff SHA512 26aaa02be4d1109dfdae08981b9fee16a10c358030ba99ae809eb241e805c50edc8ad10b1a375cd02e3160fa3de8ae6773cca55618d39ca30614f1d6662c18e5
DIST monero-0.18.3.4.tar.gz 14039924 BLAKE2B cb60f1db4f482bac3b3f5fa606bf1c78103b14f927d4636e5fda4aa96dcc08a9f990355ceb1cdc8c253245a0a2a1c98cf4fd7101d13d78ac6e7d1450192fc2db SHA512 f2708bf7698410c1509ae41148c298e352b3401e1df900b7152c25cb5ceb2f5bde68274fd37b1a328e932be50bdf93fe364561c520a15e3df7de2cdbd20d1be8
diff --git a/net-p2p/monero/monero-0.18.3.1.ebuild b/net-p2p/monero/monero-0.18.3.1.ebuild
deleted file mode 100644
index 5477acec3..000000000
--- a/net-p2p/monero/monero-0.18.3.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-DESCRIPTION="The secure, private, untraceable cryptocurrency"
-HOMEPAGE="https://github.com/monero-project/monero"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/monero-project/monero.git"
- EGIT_SUBMODULES=()
-else
- SRC_URI="https://github.com/monero-project/monero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+daemon hw-wallet readline +tools +wallet-cli +wallet-rpc"
-REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
-RESTRICT="test"
-
-DEPEND="
- acct-group/monero
- acct-user/monero
- <dev-libs/boost-1.85:=[nls]
- dev-libs/libsodium:=
- dev-libs/openssl:=
- dev-libs/randomx
- dev-libs/rapidjson
- dev-libs/supercop
- net-dns/unbound:=[threads]
- net-libs/czmq:=
- net-libs/miniupnpc:=
- readline? ( sys-libs/readline:0= )
- hw-wallet? (
- dev-libs/hidapi
- dev-libs/protobuf:=
- virtual/libusb:1
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.18.3.3-unbundle-dependencies.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- # TODO: Update CMake to install built libraries (help wanted)
- -DBUILD_SHARED_LIBS=OFF
- -DMANUAL_SUBMODULES=ON
- -DUSE_DEVICE_TREZOR=$(usex hw-wallet ON OFF)
- )
-
- use elibc_musl && mycmakeargs+=( -DSTACK_TRACE=OFF )
-
- cmake_src_configure
-}
-
-src_compile() {
- local targets=()
- use daemon && targets+=(daemon)
- use tools && targets+=(blockchain_{ancestry,blackball,db,depth,export,import,prune,prune_known_spent_data,stats,usage})
- use wallet-cli && targets+=(simplewallet)
- use wallet-rpc && targets+=(wallet_rpc_server)
- cmake_build ${targets[@]}
-}
-
-src_install() {
- einstalldocs
-
- # Install all binaries.
- find "${BUILD_DIR}/bin/" -type f -executable -print0 |
- while IFS= read -r -d '' line; do
- dobin "$line"
- done
-
- if use daemon; then
- dodoc utils/conf/monerod.conf
-
- # data-dir
- keepdir /var/lib/monero
- fowners monero:monero /var/lib/monero
- fperms 0755 /var/lib/monero
-
- # log-file dir
- keepdir /var/log/monero
- fowners monero:monero /var/log/monero
- fperms 0755 /var/log/monero
-
- # /etc/monero/monerod.conf
- insinto /etc/monero
- doins "${FILESDIR}/monerod.conf"
-
- # OpenRC
- newconfd "${FILESDIR}/monerod.confd" monerod
- newinitd "${FILESDIR}/monerod.initd" monerod
-
- # systemd
- systemd_dounit "${FILESDIR}/monerod.service"
- fi
-}
-
-pkg_postinst() {
- if use daemon; then
- elog "Start the Monero P2P daemon as a system service with"
- elog "'rc-service monerod start'. Enable it at startup with"
- elog "'rc-update add monerod default'."
- elog
- elog "Run monerod status as any user to get sync status and other stats."
- elog
- elog "The Monero blockchain can take up a lot of space (80 GiB) and is stored"
- elog "in /var/lib/monero by default. You may want to enable pruning by adding"
- elog "'prune-blockchain=1' to /etc/monero/monerod.conf to prune the blockchain"
- elog "or move the data directory to another disk."
- fi
-}
diff --git a/net-p2p/monero/monero-0.18.3.3-r1.ebuild b/net-p2p/monero/monero-0.18.3.3-r1.ebuild
deleted file mode 100644
index 36b9f1e65..000000000
--- a/net-p2p/monero/monero-0.18.3.3-r1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd
-
-DESCRIPTION="The secure, private, untraceable cryptocurrency"
-HOMEPAGE="https://github.com/monero-project/monero"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/monero-project/monero.git"
- EGIT_SUBMODULES=()
-else
- SRC_URI="https://github.com/monero-project/monero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+daemon hw-wallet readline +tools +wallet-cli +wallet-rpc"
-REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
-RESTRICT="test"
-
-DEPEND="
- acct-group/monero
- acct-user/monero
- <dev-libs/boost-1.85:=[nls]
- dev-libs/libsodium:=
- dev-libs/openssl:=
- dev-libs/randomx
- dev-libs/rapidjson
- dev-libs/supercop
- net-dns/unbound:=[threads]
- net-libs/czmq:=
- <net-libs/miniupnpc-2.2.8:=
- readline? ( sys-libs/readline:0= )
- hw-wallet? (
- dev-libs/hidapi
- dev-libs/protobuf:=
- virtual/libusb:1
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.18.3.3-unbundle-dependencies.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- # TODO: Update CMake to install built libraries (help wanted)
- -DBUILD_SHARED_LIBS=OFF
- -DMANUAL_SUBMODULES=ON
- -DUSE_DEVICE_TREZOR=$(usex hw-wallet ON OFF)
- )
-
- use elibc_musl && mycmakeargs+=( -DSTACK_TRACE=OFF )
-
- cmake_src_configure
-}
-
-src_compile() {
- local targets=()
- use daemon && targets+=(daemon)
- use tools && targets+=(blockchain_{ancestry,blackball,db,depth,export,import,prune,prune_known_spent_data,stats,usage})
- use wallet-cli && targets+=(simplewallet)
- use wallet-rpc && targets+=(wallet_rpc_server)
- cmake_build ${targets[@]}
-}
-
-src_install() {
- einstalldocs
-
- # Install all binaries.
- find "${BUILD_DIR}/bin/" -type f -executable -print0 |
- while IFS= read -r -d '' line; do
- dobin "$line"
- done
-
- if use daemon; then
- dodoc utils/conf/monerod.conf
-
- # data-dir
- keepdir /var/lib/monero
- fowners monero:monero /var/lib/monero
- fperms 0755 /var/lib/monero
-
- # log-file dir
- keepdir /var/log/monero
- fowners monero:monero /var/log/monero
- fperms 0755 /var/log/monero
-
- # /etc/monero/monerod.conf
- insinto /etc/monero
- doins "${FILESDIR}/monerod.conf"
-
- # OpenRC
- newconfd "${FILESDIR}/monerod.confd" monerod
- newinitd "${FILESDIR}/monerod.initd" monerod
-
- # systemd
- systemd_dounit "${FILESDIR}/monerod.service"
- fi
-}
-
-pkg_postinst() {
- if use daemon; then
- elog "Start the Monero P2P daemon as a system service with"
- elog "'rc-service monerod start'. Enable it at startup with"
- elog "'rc-update add monerod default'."
- elog
- elog "Run monerod status as any user to get sync status and other stats."
- elog
- elog "The Monero blockchain can take up a lot of space (200 GiB) and is stored"
- elog "in /var/lib/monero by default. You may want to enable pruning by adding"
- elog "'prune-blockchain=1' to /etc/monero/monerod.conf to prune the blockchain"
- elog "or move the data directory to another disk."
- fi
-}