aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Morretton <laurent@morretton.fr>2023-04-04 22:31:19 +0200
committerLaurent Morretton <laurent@morretton.fr>2023-04-04 22:31:19 +0200
commite9e56e828d81acdc9915bbbe36fed23dcd9dbfbc (patch)
tree0238b271a4d9efdd44f529f37e65516f56e56bf6 /net-misc
parentnet-misc/cve-client: new package, add 1.0.4, 9999 (diff)
downloadguru-e9e56e828d81acdc9915bbbe36fed23dcd9dbfbc.tar.gz
guru-e9e56e828d81acdc9915bbbe36fed23dcd9dbfbc.tar.bz2
guru-e9e56e828d81acdc9915bbbe36fed23dcd9dbfbc.zip
net-misc/tuba: new package, add 0.2.0
Signed-off-by: Laurent Morretton <laurent@morretton.fr>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tuba/Manifest1
-rw-r--r--net-misc/tuba/tuba-0.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
new file mode 100644
index 000000000..021b96761
--- /dev/null
+++ b/net-misc/tuba/Manifest
@@ -0,0 +1 @@
+DIST v0.2.0.tar.gz 233703 BLAKE2B 8131986f481031257a59a4d2902364cec042d3d773cee0dee3b1ef8628ea1e2dbb32619c6f9054b43c88a1da51a53d1877896f0082ad482387876000b47d40ab SHA512 c5e07199c950963ac6f398d36f2da760a6fa734e247ba1defc3b98f9aa53d1626cf519988a96c5c7e16f32b79d7f5ad6bec02d6eab84cc132f2f634176fdd2f5
diff --git a/net-misc/tuba/tuba-0.2.0.ebuild b/net-misc/tuba/tuba-0.2.0.ebuild
new file mode 100644
index 000000000..67322e9c1
--- /dev/null
+++ b/net-misc/tuba/tuba-0.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Mastodon client, previously known as Tooth"
+HOMEPAGE="https://github.com/GeopJr/Tuba"
+SRC_URI="https://github.com/GeopJr/${PN}/archive/refs/tags/v${PV}.tar.gz"
+
+LICENSE="CC-BY-3.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+S="${WORKDIR}/Tuba-${PV}"
+
+RDEPEND="
+ >=app-crypt/libsecret-0.20
+ >=dev-libs/glib-2.71.2
+ >=dev-libs/json-glib-1.4.4
+ >=dev-libs/libxml2-2.9.10
+ >=dev-libs/libgee-0.8.5
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.2
+ >=net-libs/libsoup-3
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ $(vala_depend)
+ virtual/pkgconfig
+"
+
+VALA_MIN_API_VERSION=0.48
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}