aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-11-10 15:53:26 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-11-10 16:17:42 +0100
commit280ce797d272e1a80bd0254ce6304ec5b1700cb9 (patch)
treea429b899da1a8a7451cd9eb0389d42f0a171ad8e /gui-apps
parentgui-apps/nwg-panel: drop 0.9.41 (diff)
downloadguru-280ce797d272e1a80bd0254ce6304ec5b1700cb9.tar.gz
guru-280ce797d272e1a80bd0254ce6304ec5b1700cb9.tar.bz2
guru-280ce797d272e1a80bd0254ce6304ec5b1700cb9.zip
gui-apps/nwg-panel: add 0.9.47
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-panel/Manifest1
-rw-r--r--gui-apps/nwg-panel/nwg-panel-0.9.47.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gui-apps/nwg-panel/Manifest b/gui-apps/nwg-panel/Manifest
index 15eb98775..2d57810aa 100644
--- a/gui-apps/nwg-panel/Manifest
+++ b/gui-apps/nwg-panel/Manifest
@@ -2,3 +2,4 @@ DIST nwg-panel-0.9.42.tar.gz 238220 BLAKE2B 4231237783cf374be9eae51af51a560bec9a
DIST nwg-panel-0.9.43.tar.gz 238254 BLAKE2B e358075460b070562fde23b4dc310112836dcaef39a77904f9d2669b0d267660d6a86f69d2206d24ef30e317c5600529c6e9a98fd36399856be04404826f885b SHA512 4db6f5f4cce63d73eb8d436fded90889ee16f9843e0d22977562daebabdeb0dbfdeb99ac20d414888d28fe4b2d57baaa1560cd4ba5190e9fff5ed1810aac1d2a
DIST nwg-panel-0.9.44.tar.gz 238260 BLAKE2B 5c0a0ebbbea556ff5cee4d4bccafaa94b7ef8c87e4e98b4e622a4ce17d1d37bfb9ef8d56957aca07b33a45c29844b2dc3ac3908331302210865c4ce1693ed58e SHA512 925c4efdda9e24b4b27ed5d925b47d5e3bf592380af44f67b795497dcbd47ac27ddb0b1f5dfccc350ce8d763eca4d6d78e7c8b6406d0feff977b8a6d31957680
DIST nwg-panel-0.9.46.tar.gz 238422 BLAKE2B 7d4d94f663c8c4ecfa865ac5c4b53f274f14f03e8065650dfb6f72c7abdf5df0082fd698437c07aff2f7a2f869a752a479cd08f514ff4ff5150113f7b155177c SHA512 08551945ca6227bafdd58e933e042faff3c10eb98444be15f8de563cc776813a0bd1e8510fb7ecf418527660c7f607dac8b6cab975f85ad6a797f1c034a7a686
+DIST nwg-panel-0.9.47.tar.gz 238407 BLAKE2B 3716f49ffd16c4a13a2e6ecba4bac73c0b60c34450590e2bb942b50970cdbaf627c97c7eabe9ab61a425984b565949848df691c384610e53938f78dfdb57d0c1 SHA512 73c00402eca9e4d5eafda4dc7a744e8aa62e63d1aaa5fd20964b82b2f166b08680fcb5d1c1a991ea53c6083458b92a6880cb85dadcb1d99260e85ce0263d5d8b
diff --git a/gui-apps/nwg-panel/nwg-panel-0.9.47.ebuild b/gui-apps/nwg-panel/nwg-panel-0.9.47.ebuild
new file mode 100644
index 000000000..0a4665691
--- /dev/null
+++ b/gui-apps/nwg-panel/nwg-panel-0.9.47.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit desktop distutils-r1 systemd xdg-utils
+
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nwg-piotr/nwg-panel.git"
+else
+ SRC_URI="https://github.com/nwg-piotr/nwg-panel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="GTK3-based panel for sway and Hyprland Wayland compositors"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-panel"
+LICENSE="MIT"
+
+SLOT="0"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/i3ipc[${PYTHON_USEDEP}]
+ dev-python/dasbus[${PYTHON_USEDEP}]
+ gui-apps/nwg-icon-picker
+ media-sound/playerctl
+ gui-libs/gtk-layer-shell[introspection]
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu nwg-panel-config.desktop
+ domenu nwg-processes.desktop
+ doicon nwg-panel.svg
+ doicon nwg-processes.svg
+ doicon nwg-shell.svg
+ systemd_dounit nwg-panel.service
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}