aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Sweeney <agooglygooglr@gmail.com>2024-08-18 13:19:27 -0400
committerDale Sweeney <agooglygooglr@gmail.com>2024-08-18 13:19:27 -0400
commitad679adf7aa25b36405bff9e59d07b13f3c41dee (patch)
tree8e4160cbbd0dcfb08f40e6c78b74440477514843
parentnet-misc/wlvncc: Add snapshot ebuild (diff)
downloadguru-ad679adf7aa25b36405bff9e59d07b13f3c41dee.tar.gz
guru-ad679adf7aa25b36405bff9e59d07b13f3c41dee.tar.bz2
guru-ad679adf7aa25b36405bff9e59d07b13f3c41dee.zip
dev-util/dmg2img: add 20240818
Signed-off-by: Dale Sweeney <agooglygooglr@gmail.com>
-rw-r--r--dev-util/dmg2img/Manifest1
-rw-r--r--dev-util/dmg2img/dmg2img-20240818.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/dmg2img/Manifest b/dev-util/dmg2img/Manifest
new file mode 100644
index 000000000..1216b52a0
--- /dev/null
+++ b/dev-util/dmg2img/Manifest
@@ -0,0 +1 @@
+DIST a3e413489ccdd05431401357bf21690536425012.tar.gz 24904 BLAKE2B 01229b9b91873a718a69157565614340e13116a54d4440185423df8799550b7b84512cfe7f1c4cbcb4a3af538094c0567c41949b924f165fa816669cd7006845 SHA512 09da0c0d8680412801be6edccddc7ef588ea8ab0c0637e99652e34a387c1d456682b4881d329bed2ba0c76172b225441b6000cc73f5398853cbf34b1cb554d97
diff --git a/dev-util/dmg2img/dmg2img-20240818.ebuild b/dev-util/dmg2img/dmg2img-20240818.ebuild
new file mode 100644
index 000000000..573d8049f
--- /dev/null
+++ b/dev-util/dmg2img/dmg2img-20240818.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+COMMIT="a3e413489ccdd05431401357bf21690536425012"
+
+inherit toolchain-funcs
+
+SRC_URI="https://github.com/Lekensteyn/dmg2img/archive/${COMMIT}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+DESCRIPTION="Convert Apple disk images to IMG format."
+HOMEPAGE="https://github.com/Lekensteyn/dmg2img"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="lzfse"
+
+DEPEND="
+ app-arch/bzip2
+ dev-libs/openssl
+ sys-libs/zlib
+ lzfse? ( dev-libs/lzfse )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_compile() {
+ emake HAVE_LZFSE=$(usex lzfse 1 0) CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+}