From 9a92eb8397cc1037b266151e8aef58829bfff826 Mon Sep 17 00:00:00 2001
From: Diego Elio Pettenò <flameeyes@gentoo.org>
Date: Mon, 26 Jun 2006 05:31:12 +0000
Subject: Add patch to fix argument parsing on unsigned-char arches.
 Package-Manager: portage-2.1.1_pre1-r2

---
 sys-block/unieject/ChangeLog                      |  9 ++-
 sys-block/unieject/files/digest-unieject-5.3.1-r1 |  3 +
 sys-block/unieject/files/unieject-5.3.1-ppc.patch | 15 +++++
 sys-block/unieject/unieject-5.3.1-r1.ebuild       | 82 +++++++++++++++++++++++
 4 files changed, 108 insertions(+), 1 deletion(-)
 create mode 100644 sys-block/unieject/files/digest-unieject-5.3.1-r1
 create mode 100644 sys-block/unieject/files/unieject-5.3.1-ppc.patch
 create mode 100644 sys-block/unieject/unieject-5.3.1-r1.ebuild

(limited to 'sys-block')

diff --git a/sys-block/unieject/ChangeLog b/sys-block/unieject/ChangeLog
index db8434eac216..7f135f39e7bc 100644
--- a/sys-block/unieject/ChangeLog
+++ b/sys-block/unieject/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for sys-block/unieject
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.29 2006/06/24 02:28:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/ChangeLog,v 1.30 2006/06/26 05:31:12 flameeyes Exp $
+
+*unieject-5.3.1-r1 (26 Jun 2006)
+
+  26 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +files/unieject-5.3.1-ppc.patch, -unieject-5.3.1.ebuild,
+  +unieject-5.3.1-r1.ebuild:
+  Add patch to fix argument parsing on unsigned-char arches.
 
 *unieject-5.3.1 (24 Jun 2006)
 
diff --git a/sys-block/unieject/files/digest-unieject-5.3.1-r1 b/sys-block/unieject/files/digest-unieject-5.3.1-r1
new file mode 100644
index 000000000000..b86dc18b8bad
--- /dev/null
+++ b/sys-block/unieject/files/digest-unieject-5.3.1-r1
@@ -0,0 +1,3 @@
+MD5 3a824816ec40edbf91be42596c76d029 unieject-5.3.1.tar.bz2 323895
+RMD160 31590af2fca9dea9d1ccdbac4e434ec4ecffade2 unieject-5.3.1.tar.bz2 323895
+SHA256 c670e618b0e5f12cdad6949431dec73b64786ff1de078ca6d46e163bf9897dca unieject-5.3.1.tar.bz2 323895
diff --git a/sys-block/unieject/files/unieject-5.3.1-ppc.patch b/sys-block/unieject/files/unieject-5.3.1-ppc.patch
new file mode 100644
index 000000000000..bca81e79ef78
--- /dev/null
+++ b/sys-block/unieject/files/unieject-5.3.1-ppc.patch
@@ -0,0 +1,15 @@
+Index: unieject-5.3.1/unieject.c
+===================================================================
+--- unieject-5.3.1.orig/unieject.c
++++ unieject-5.3.1/unieject.c
+@@ -141,8 +141,8 @@ static void parse_configuration()
+ /* Parse a all options. */
+ static int parse_options (int argc, const char *argv[])
+ {
+-	char tmpopt;
+-	char opt = OP_IGNORE; /* used for argument parsing */
++	int8_t tmpopt;
++	int8_t opt = OP_IGNORE; /* used for argument parsing */
+ 	
+ 	struct poptOption optionsTable[] = {
+ 		{ "trayclose",		't', POPT_ARG_VAL, &opts.eject, 0,
diff --git a/sys-block/unieject/unieject-5.3.1-r1.ebuild b/sys-block/unieject/unieject-5.3.1-r1.ebuild
new file mode 100644
index 000000000000..efb751f9ca12
--- /dev/null
+++ b/sys-block/unieject/unieject-5.3.1-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/unieject/unieject-5.3.1-r1.ebuild,v 1.1 2006/06/26 05:31:12 flameeyes Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Multiplatform command to eject and load CD-Rom drives"
+HOMEPAGE="http://dev.gentoo.org/~flameeyes/projects"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls pmount"
+
+RDEPEND=">=dev-libs/libcdio-0.75-r1
+	dev-libs/popt
+	>=dev-libs/confuse-2.5
+	nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+	nls? ( sys-devel/gettext )
+	sys-apps/sed"
+RDEPEND="${RDEPEND}
+	pmount? ( sys-apps/pmount )
+	!sys-apps/eject
+	!sys-block/eject-bsd"
+
+PROVIDE="virtual/eject"
+
+pkg_setup() {
+	use pmount && enewgroup plugdev
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	epatch "${FILESDIR}/${P}-ppc.patch"
+
+	# libcdio-0.75-r1 in Gentoo is fixed, so no need to ask 0.76 either on
+	# FreeBSD.
+	sed -i -e '/freebsd/s:libcdiomin="0\.76":libcdiomin="0.75":' \
+		${S}/configure
+
+	elibtoolize
+}
+
+src_compile() {
+	use pmount && append-ldflags "-Wl,-z,now"
+
+	econf \
+		$(use_enable nls) \
+		--enable-lock-workaround \
+		--disable-dependency-tracking \
+		--disable-doc \
+		|| die "econf failed"
+	emake || die "emake failed"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install
+	dodoc README ChangeLog NEWS AUTHORS unieject.conf.sample
+
+	# Symlink to eject to provide a good virtual/eject
+	dosym unieject.1.gz /usr/share/man/man1/eject.1.gz
+	dosym unieject /usr/bin/eject
+
+	# If we enable support for pmount, we need to change the installed
+	# configuration file to enable the unmount wrapper, and we also set the
+	# command setuid root but in group plugdev, so that it's inlined with pmount
+	# itself.
+	if use pmount; then
+		fowners root:plugdev /usr/bin/unieject
+		fperms 1710 /usr/bin/unieject
+		chmod +s "${D}/usr/bin/unieject"
+
+		dodir /etc
+		sed -e 's:^# \(unmount-wrapper = \):\1:' \
+			"${S}/unieject.conf.sample" \
+			> "${D}/etc/unieject.conf"
+	fi
+}
-- 
cgit v1.2.3-65-gdbad