From 2d4e645b92f0150bf4dab2c1a8f39b3f5505f7aa Mon Sep 17 00:00:00 2001
From: Martin Schlemmer <azarah@gentoo.org>
Date: Wed, 16 Jan 2002 21:52:11 +0000
Subject: new version; resolve bug #84; remove older versions

---
 net-nds/openldap/files/digest-openldap-2.0.21 |  1 +
 net-nds/openldap/openldap-2.0.21.ebuild       | 77 +++++++++++++++++++++++++++
 2 files changed, 78 insertions(+)
 create mode 100644 net-nds/openldap/files/digest-openldap-2.0.21
 create mode 100644 net-nds/openldap/openldap-2.0.21.ebuild

(limited to 'net-nds/openldap')

diff --git a/net-nds/openldap/files/digest-openldap-2.0.21 b/net-nds/openldap/files/digest-openldap-2.0.21
new file mode 100644
index 000000000000..9937b4d804c3
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.21
@@ -0,0 +1 @@
+MD5 a4561f9119818dacfa774de75be555d3 openldap-2.0.21.tgz 1306624
diff --git a/net-nds/openldap/openldap-2.0.21.ebuild b/net-nds/openldap/openldap-2.0.21.ebuild
new file mode 100644
index 000000000000..bac4cdcc80d3
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.21.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.21.ebuild,v 1.1 2002/01/16 21:52:11 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+	>=sys-libs/ncurses-5.1
+        tcpd?     ( >=sys-apps/tcp-wrappers-7.6 )
+        ssl?      ( >=dev-libs/openssl-0.9.6 )
+        readline? ( >=sys-libs/readline-4.1 )
+        gdbm?     ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+        >=sys-libs/ncurses-5.1
+        gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+
+src_compile() {
+	local myconf
+
+	use tcpd     && myconf="${myconf} --enable-wrappers"
+	use ssl      && myconf="${myconf} --with-tls"
+	use readline && myconf="${myconf} --with-readline"
+	use readline || myconf="${myconf} --without-readline"
+	use gdbm     && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+	use gdbm     || myconf="${myconf} --disable-ldbm"
+	use ipv6     && myconf="${myconf} --enable-ipv6"
+
+	./configure --host=${CHOST} \
+		--enable-passwd \
+		--enable-shell \
+		--enable-shared \
+		--enable-static \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--localstatedir=/var/state \
+		--mandir=/usr/share/man \
+		--libexecdir=/usr/lib/openldap \
+		${myconf} || die "bad configure"
+
+	make depend || die
+	make || die
+	cd tests ; make || die
+}
+
+src_install() {
+	make prefix=${D}/usr \
+		sysconfdir=${D}/etc/openldap \
+		localstatedir=${D}/var/state \
+		mandir=${D}/usr/share/man \
+		libexecdir=${D}/usr/lib/openldap \
+		install || die "install problem"
+
+	#fix ${D} in manpages
+	cd ${S}/doc/man
+	make DESTDIR=${D} clean all install || die "install doc problem"
+	cd ${S}
+
+	dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+	docinto rfc ; dodoc doc/rfc/*.txt
+	docinto devel ; dodoc doc/devel/*
+
+	exeinto /etc/init.d
+	newexe ${FILESDIR}/slapd.rc6 slapd
+	newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+	cd ${D}/etc/openldap
+	for i in *
+	do
+		dosed $i
+	done
+}
-- 
cgit v1.2.3-65-gdbad