summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/setserial')
-rwxr-xr-xsys-apps/setserial/files/serial29
-rw-r--r--sys-apps/setserial/setserial-2.17-r3.ebuild43
2 files changed, 0 insertions, 72 deletions
diff --git a/sys-apps/setserial/files/serial b/sys-apps/setserial/files/serial
deleted file mode 100755
index cbbd01755d81..000000000000
--- a/sys-apps/setserial/files/serial
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/setserial/files/serial,v 1.3 2007/06/13 07:51:51 vapier Exp $
-
-depend() {
- need localmount
-}
-
-start() {
- [ ! -e /etc/serial.conf ] && return 0
-
- # load the module if need be
- if [ -e /proc/modules ] ; then
- modprobe -q serial
- fi
-
- grep -v "^#\|^ \|^$" /etc/serial.conf | while read device args
- do
- ebegin "Setting ${device} to $args"
- setserial -b ${device} ${args}
- eend $?
- done
-
- return 0
-}
-
-
-# vim:ts=4
diff --git a/sys-apps/setserial/setserial-2.17-r3.ebuild b/sys-apps/setserial/setserial-2.17-r3.ebuild
deleted file mode 100644
index 5fab96e3be24..000000000000
--- a/sys-apps/setserial/setserial-2.17-r3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/setserial/setserial-2.17-r3.ebuild,v 1.3 2010/10/08 02:16:31 leio Exp $
-
-inherit eutils
-
-DESCRIPTION="Configure your serial ports with it"
-HOMEPAGE="http://setserial.sourceforge.net/"
-SRC_URI="ftp://tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz
- ftp://ftp.sunsite.org.uk/Mirrors/tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-spelling.patch
- epatch "${FILESDIR}"/${P}-manpage-updates.patch
- epatch "${FILESDIR}"/${P}-headers.patch
- epatch "${FILESDIR}"/${P}-build.patch
-}
-
-src_compile() {
- econf || die
- emake setserial || die
-}
-
-src_install() {
- doman setserial.8
- into /
- dobin setserial || die
-
- insinto /etc
- doins serial.conf
- doinitd "${FILESDIR}"/serial
-
- dodoc README
- docinto txt
- dodoc Documentation/*
-}