summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www')
-rw-r--r--net-www/bozohttpd/ChangeLog9
-rw-r--r--net-www/bozohttpd/Manifest7
-rw-r--r--net-www/bozohttpd/bozohttpd-20040218.ebuild36
-rw-r--r--net-www/bozohttpd/files/bozohttpd-20040218.Makefile33
-rw-r--r--net-www/bozohttpd/files/bozohttpd-20040218.conffile11
-rw-r--r--net-www/bozohttpd/files/bozohttpd-20040218.initscript38
-rw-r--r--net-www/bozohttpd/files/digest-bozohttpd-200402181
-rw-r--r--net-www/bozohttpd/metadata.xml13
8 files changed, 148 insertions, 0 deletions
diff --git a/net-www/bozohttpd/ChangeLog b/net-www/bozohttpd/ChangeLog
new file mode 100644
index 000000000000..39dc97b3ba54
--- /dev/null
+++ b/net-www/bozohttpd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/bozohttpd
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/bozohttpd/ChangeLog,v 1.1 2004/06/24 12:15:32 s4t4n Exp $
+
+*bozohttpd-20040218 (24 Jun 2004)
+
+ 24 Jun 2004; Michele Noberasco <s4t4n@gentoo.org> bozohttpd-20040218.ebuild:
+ Initial import. Close bug #30573
+
diff --git a/net-www/bozohttpd/Manifest b/net-www/bozohttpd/Manifest
new file mode 100644
index 000000000000..11c628157cd4
--- /dev/null
+++ b/net-www/bozohttpd/Manifest
@@ -0,0 +1,7 @@
+MD5 a24408f4769151372dbee5c6b9de8d08 bozohttpd-20040218.ebuild 961
+MD5 24e3ca649cb73e390bf9fcd63a96d88c ChangeLog 364
+MD5 8574132eb9ab5f7b8455a49e11860ce4 metadata.xml 401
+MD5 10a103f61bdbfd7cd72c44bd9da660b4 files/digest-bozohttpd-20040218 70
+MD5 8ba8e430cb53030e75557268c3b5d472 files/bozohttpd-20040218.conffile 221
+MD5 7df06f4ffdec8f1741eea1a9dcbb3e0d files/bozohttpd-20040218.initscript 960
+MD5 c099ee5b2237f0c0e202fe25980e3877 files/bozohttpd-20040218.Makefile 534
diff --git a/net-www/bozohttpd/bozohttpd-20040218.ebuild b/net-www/bozohttpd/bozohttpd-20040218.ebuild
new file mode 100644
index 000000000000..12ffa3584464
--- /dev/null
+++ b/net-www/bozohttpd/bozohttpd-20040218.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/bozohttpd/bozohttpd-20040218.ebuild,v 1.1 2004/06/24 12:15:32 s4t4n Exp $
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND=">=dev-libs/openssl-0.9.7d-r1"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # We substitute the Makefile because the original works only with BSD make
+ cd ${S}
+ rm -f Makefile
+ cp ${FILESDIR}/${P}.Makefile Makefile
+}
+
+src_install ()
+{
+ dodir usr/bin
+ dodir usr/share/man
+ PREFIX="${D}/usr" einstall || die
+
+ insinto /etc/conf.d; newins ${FILESDIR}/${P}.conffile bozohttpd
+ exeinto /etc/init.d; newexe ${FILESDIR}/${P}.initscript bozohttpd
+}
+
+pkg_postinst()
+{
+ einfo "Remember to edit /etc/conf.d/bozohttpd to suit your needs."
+}
diff --git a/net-www/bozohttpd/files/bozohttpd-20040218.Makefile b/net-www/bozohttpd/files/bozohttpd-20040218.Makefile
new file mode 100644
index 000000000000..709eed603034
--- /dev/null
+++ b/net-www/bozohttpd/files/bozohttpd-20040218.Makefile
@@ -0,0 +1,33 @@
+ifndef MANDIR
+ MANDIR = share/man/man8
+endif
+ifndef PREFIX
+ PREFIX = /usr/local
+endif
+ifndef CC
+ CC = gcc
+endif
+ifndef INSTALL
+ INSTALL = /bin/install
+endif
+
+SRCS = bozohttpd.c
+OBJ = bozohttpd
+
+all: bozohttpd
+
+bozohttpd:
+ $(CC) $(CFLAGS) -o $(OBJ) $(SRCS) -lssl -lcrypto
+
+clean:
+ rm -f $(OBJ)
+ rm -f *~
+
+install:: bozohttpd
+ $(INSTALL) -s -m 755 $(OBJ) $(PREFIX)/bin
+ $(INSTALL) -d $(PREFIX)/$(MANDIR)
+ $(INSTALL) -m 644 $(OBJ).8 $(PREFIX)/$(MANDIR)
+
+uninstall::
+ -rm -f $(PREFIX)/bin/$(OBJ)
+ -rm -f $(PREFIX)/$(MANDIR)/$(OBJ).8
diff --git a/net-www/bozohttpd/files/bozohttpd-20040218.conffile b/net-www/bozohttpd/files/bozohttpd-20040218.conffile
new file mode 100644
index 000000000000..055a52e3d2aa
--- /dev/null
+++ b/net-www/bozohttpd/files/bozohttpd-20040218.conffile
@@ -0,0 +1,11 @@
+# Config file for /etc/init.d/bozohttpd
+
+# necessary stuff
+DATADIR=/var/www/localhost/htdocs
+BIND_ADDRESS=localhost
+LISTEN_PORT=80
+
+# optional stuff
+#USER=daemon
+#INDEX_DEFAULT=index.php
+#APPEND="-a -C .php /usr/bin/php"
diff --git a/net-www/bozohttpd/files/bozohttpd-20040218.initscript b/net-www/bozohttpd/files/bozohttpd-20040218.initscript
new file mode 100644
index 000000000000..bdbd40445f50
--- /dev/null
+++ b/net-www/bozohttpd/files/bozohttpd-20040218.initscript
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header:
+
+#NB: Config is in /etc/conf.d/bozohttpd
+
+
+depend() {
+ need logger net
+}
+
+checkconfig() {
+ if [ -z "$DATADIR" ] || [ -z "$BIND_ADDRESS" ] || [ -z "$LISTEN_PORT" ]; then
+ eerror "You need to setup DATADIR, BIND_ADDRESS and LISTEN PORT in /etc/conf.d/bozohttpd first"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ local params=""
+
+ [ -n "$USER" ] && params="$params -U $USER"
+ [ -n "$INDEX_DEFAULT" ] && params="$params -x $INDEX_DEFAULT"
+ [ -n "$APPEND" ] && params="$params $APPEND"
+
+ ebegin "Starting bozohttpd"
+ start-stop-daemon --start --exec /usr/bin/bozohttpd -- -b -i $BIND_ADDRESS -I $LISTEN_PORT -X ${params} $DATADIR
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping bozohttpd"
+ start-stop-daemon --stop --exec /usr/bin/bozohttpd
+ eend ${?}
+}
diff --git a/net-www/bozohttpd/files/digest-bozohttpd-20040218 b/net-www/bozohttpd/files/digest-bozohttpd-20040218
new file mode 100644
index 000000000000..24eab6bcf915
--- /dev/null
+++ b/net-www/bozohttpd/files/digest-bozohttpd-20040218
@@ -0,0 +1 @@
+MD5 66753d2968b1a4570901f235861841c1 bozohttpd-20040218.tar.bz2 31936
diff --git a/net-www/bozohttpd/metadata.xml b/net-www/bozohttpd/metadata.xml
new file mode 100644
index 000000000000..179074a802d6
--- /dev/null
+++ b/net-www/bozohttpd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+<maintainer>
+ <name>Michele Noberasco</name>
+ <email>s4t4n@gentoo.org</email>
+</maintainer>
+<longdescription>
+ bozohttpd is designed to be small, simple and relatively
+ featureless, hopefully increasing its security.
+</longdescription>
+</pkgmetadata>