summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsdl/libsdl-1.2.6-r3.ebuild')
-rw-r--r--media-libs/libsdl/libsdl-1.2.6-r3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-libs/libsdl/libsdl-1.2.6-r3.ebuild b/media-libs/libsdl/libsdl-1.2.6-r3.ebuild
index 2b9764fd131c..d166cdab6e73 100644
--- a/media-libs/libsdl/libsdl-1.2.6-r3.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.6-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6-r3.ebuild,v 1.14 2005/01/14 00:59:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6-r3.ebuild,v 1.15 2005/02/25 21:02:09 chriswhite Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Simple Direct Media Layer"
HOMEPAGE="http://www.libsdl.org/"
@@ -60,6 +60,9 @@ src_compile() {
|| myconf="${myconf} --enable-video-dummy"
use nojoystick && myconf="${myconf} --disable-joystick"
+ # filtering -fomit-frame-pointer as per bug #82618
+ filter-flags -fomit-frame-pointer
+
# asm is b0rken in 1.2.6
# http://www.libsdl.org/pipermail/sdl/2003-October/057304.html
# `use_enable x86 nasm` \