summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sam2p')
-rw-r--r--media-gfx/sam2p/ChangeLog8
-rw-r--r--media-gfx/sam2p/Manifest6
-rw-r--r--media-gfx/sam2p/files/digest-sam2p-0.431
-rw-r--r--media-gfx/sam2p/sam2p-0.43.ebuild23
-rw-r--r--media-gfx/sam2p/sam2p-0.44.ebuild8
5 files changed, 13 insertions, 33 deletions
diff --git a/media-gfx/sam2p/ChangeLog b/media-gfx/sam2p/ChangeLog
index 8dfadd81f6c1..4f44a6447766 100644
--- a/media-gfx/sam2p/ChangeLog
+++ b/media-gfx/sam2p/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/sam2p
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.8 2004/07/01 10:50:26 eradicator Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.9 2005/05/13 19:54:45 twp Exp $
+
+ 13 May 2005; Tom Payne <twp@gentoo.org> -sam2p-0.43.ebuild,
+ sam2p-0.44.ebuild:
+ Update to use toolchain-funcs. Remove old version.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> sam2p-0.43.ebuild:
virtual/glibc -> virtual/libc
diff --git a/media-gfx/sam2p/Manifest b/media-gfx/sam2p/Manifest
index 6394e29721a4..01a033c0139e 100644
--- a/media-gfx/sam2p/Manifest
+++ b/media-gfx/sam2p/Manifest
@@ -1,6 +1,4 @@
-MD5 ca0972f1e70390f09ae7cb56b0f68cb5 ChangeLog 860
+MD5 792298ac6ba8af29dae77cbf578a777b sam2p-0.44.ebuild 796
+MD5 58002173c18db4381ad4c662a1c24100 ChangeLog 990
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
-MD5 56ef7f546699ba0da54799f121e009bf sam2p-0.43.ebuild 599
-MD5 98e33610ffebd5bf209ca35ee3dfe0d4 sam2p-0.44.ebuild 784
-MD5 0d42c420abed96b2402777eb8a09b898 files/digest-sam2p-0.43 62
MD5 83eb0bb62aef95179599e800262049da files/digest-sam2p-0.44 63
diff --git a/media-gfx/sam2p/files/digest-sam2p-0.43 b/media-gfx/sam2p/files/digest-sam2p-0.43
deleted file mode 100644
index dbcb2728c1ea..000000000000
--- a/media-gfx/sam2p/files/digest-sam2p-0.43
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ac968e3cd8d5eb4ca9420de77ee32438 sam2p-0.43.tar.gz 515941
diff --git a/media-gfx/sam2p/sam2p-0.43.ebuild b/media-gfx/sam2p/sam2p-0.43.ebuild
deleted file mode 100644
index 79279d5eb560..000000000000
--- a/media-gfx/sam2p/sam2p-0.43.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.43.ebuild,v 1.4 2004/07/01 10:50:26 eradicator Exp $
-
-DESCRIPTION="A utility to convert raster images to PDF and others"
-HOMEPAGE="http://www.inf.bme.hu/~pts/sam2p/"
-SRC_URI="http://www.inf.bme.hu/~pts/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="gif"
-DEPEND="virtual/libc"
-
-src_compile() {
- local myconf="--enable-lzw `use_enable gif`"
- econf ${myconf} || die
- make || die
-}
-
-src_install() {
- einstall
- dodoc README
-}
diff --git a/media-gfx/sam2p/sam2p-0.44.ebuild b/media-gfx/sam2p/sam2p-0.44.ebuild
index 5770b7885037..779ab781cbdd 100644
--- a/media-gfx/sam2p/sam2p-0.44.ebuild
+++ b/media-gfx/sam2p/sam2p-0.44.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.44.ebuild,v 1.4 2004/06/24 22:49:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.44.ebuild,v 1.5 2005/05/13 19:54:45 twp Exp $
DESCRIPTION="A utility to convert raster images to PDF and others"
HOMEPAGE="http://www.inf.bme.hu/~pts/sam2p/"
@@ -14,11 +14,13 @@ DEPEND="dev-lang/perl
sys-devel/gcc-config"
S=${WORKDIR}
+inherit toolchain-funcs
+
src_compile() {
local myconf="--enable-lzw `use_enable gif`"
# Makedep borks if distcc is used, so disable it for econf by
# overriding the path to g++
- CXX="$(gcc-config -B)/g++" econf ${myconf} || die
+ CXX="$(tc-getCXX)" econf ${myconf} || die
make || die
}