summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnomeprint/ChangeLog13
-rw-r--r--gnome-base/libgnomeprint/files/digest-libgnomeprint-2.18.33
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-2.18.3.ebuild40
3 files changed, 54 insertions, 2 deletions
diff --git a/gnome-base/libgnomeprint/ChangeLog b/gnome-base/libgnomeprint/ChangeLog
index 35debd8e9d13..79ecfe85aaca 100644
--- a/gnome-base/libgnomeprint/ChangeLog
+++ b/gnome-base/libgnomeprint/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/libgnomeprint
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.140 2007/11/27 03:54:30 jer Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.141 2008/01/30 21:54:12 eva Exp $
+
+*libgnomeprint-2.18.3 (30 Jan 2008)
+
+ 30 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +libgnomeprint-2.18.3.ebuild:
+ bump to 2.18.3
+ * Fix use of uninitialized variable (Coverity)
+ * Fix some dead code (Coverity)
+ * Remove more popt usage
27 Nov 2007; Jeroen Roovers <jer@gentoo.org> libgnomeprint-2.18.2.ebuild:
Stable for HPPA (bug #199322).
diff --git a/gnome-base/libgnomeprint/files/digest-libgnomeprint-2.18.3 b/gnome-base/libgnomeprint/files/digest-libgnomeprint-2.18.3
new file mode 100644
index 000000000000..1d15972577cf
--- /dev/null
+++ b/gnome-base/libgnomeprint/files/digest-libgnomeprint-2.18.3
@@ -0,0 +1,3 @@
+MD5 cfa7dc988ba5f7f360b68edd33685a27 libgnomeprint-2.18.3.tar.bz2 880852
+RMD160 12e75d110d5876ffd3011818b1d0e416809e175d libgnomeprint-2.18.3.tar.bz2 880852
+SHA256 3022383d41270795ff709d3232ac528813fdb8173f9488e04193f0311e816911 libgnomeprint-2.18.3.tar.bz2 880852
diff --git a/gnome-base/libgnomeprint/libgnomeprint-2.18.3.ebuild b/gnome-base/libgnomeprint/libgnomeprint-2.18.3.ebuild
new file mode 100644
index 000000000000..e6e7165540f2
--- /dev/null
+++ b/gnome-base/libgnomeprint/libgnomeprint-2.18.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.18.3.ebuild,v 1.1 2008/01/30 21:54:12 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Printer handling for Gnome"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cups doc"
+
+RDEPEND=">=dev-libs/glib-2
+ >=media-libs/libart_lgpl-2.3.7
+ >=x11-libs/pango-1.5
+ >=dev-libs/libxml2-2.4.23
+ >=media-libs/fontconfig-1
+ >=media-libs/freetype-2.0.5
+ sys-libs/zlib
+ cups? (
+ >=net-print/cups-1.1.20
+ >=net-print/libgnomecups-0.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/flex
+ sys-devel/bison
+ doc? (
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/gtk-doc-0.9 )"
+
+DOCS="AUTHORS BUGS ChangeLog* NEWS README"
+USE_DESTDIR="1"
+
+pkg_setup() {
+ G2CONF="$(use_with cups)"
+}