summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild
index 89aa416c9110..e4bc32b392f0 100644
--- a/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild
+++ b/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild,v 1.2 2010/02/08 08:44:19 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.2.ebuild,v 1.3 2010/02/28 13:45:43 arfrever Exp $
EAPI="2"
-
-NEED_PYTHON="2.5"
+PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
-inherit eutils distutils
+inherit distutils eutils
DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
@@ -26,7 +25,7 @@ DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
PYTHON_MODNAME="ptrace"
src_prepare() {
- python_copy_sources --no-link
+ python_copy_sources
conversion() {
[[ "${PYTHON_ABI}" == 2.* ]] && return