summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cgi/ChangeLog5
-rw-r--r--dev-haskell/cgi/cgi-3001.1.1.ebuild6
-rw-r--r--dev-haskell/glut/ChangeLog5
-rw-r--r--dev-haskell/glut/glut-2.1.1.ebuild6
4 files changed, 14 insertions, 8 deletions
diff --git a/dev-haskell/cgi/ChangeLog b/dev-haskell/cgi/ChangeLog
index 273f5674a2a7..2d2077374bef 100644
--- a/dev-haskell/cgi/ChangeLog
+++ b/dev-haskell/cgi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/cgi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/ChangeLog,v 1.8 2007/12/12 13:20:47 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/ChangeLog,v 1.9 2007/12/14 01:33:09 dcoutts Exp $
+
+ 14 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> cgi-3001.1.1.ebuild:
+ Updates for upward compatability with cabal-1.2 and ghc-6.8
12 Dec 2007; Ferris McCormick <fmccor@gentoo.org> cgi-3001.1.1.ebuild:
Sparc stable --- part of Bug #201984.
diff --git a/dev-haskell/cgi/cgi-3001.1.1.ebuild b/dev-haskell/cgi/cgi-3001.1.1.ebuild
index 0eaff10308f4..7105db25ff46 100644
--- a/dev-haskell/cgi/cgi-3001.1.1.ebuild
+++ b/dev-haskell/cgi/cgi-3001.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/cgi-3001.1.1.ebuild,v 1.4 2007/12/12 13:20:47 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cgi/cgi-3001.1.1.ebuild,v 1.5 2007/12/14 01:33:09 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -23,8 +23,8 @@ DEPEND=">=dev-lang/ghc-6.6
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
-# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
src_unpack() {
unpack "${A}"
- sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" "${S}/Setup.hs"
+
+ cabal-mksetup
}
diff --git a/dev-haskell/glut/ChangeLog b/dev-haskell/glut/ChangeLog
index a5f8f1e81119..14cb3e6b6add 100644
--- a/dev-haskell/glut/ChangeLog
+++ b/dev-haskell/glut/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/glut
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/ChangeLog,v 1.4 2007/12/12 13:46:21 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/ChangeLog,v 1.5 2007/12/14 01:34:59 dcoutts Exp $
+
+ 14 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> glut-2.1.1.ebuild:
+ Updates for upward compatability with cabal-1.2 and ghc-6.8
12 Dec 2007; Ferris McCormick <fmccor@gentoo.org> glut-2.1.1.ebuild:
Add ~sparc keyword (completeness with bug #201984)
diff --git a/dev-haskell/glut/glut-2.1.1.ebuild b/dev-haskell/glut/glut-2.1.1.ebuild
index 858f2265810f..29ccd3ce25f4 100644
--- a/dev-haskell/glut/glut-2.1.1.ebuild
+++ b/dev-haskell/glut/glut-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.1.1.ebuild,v 1.4 2007/12/12 13:46:21 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.1.1.ebuild,v 1.5 2007/12/14 01:34:59 dcoutts Exp $
CABAL_FEATURES="haddock lib profile"
inherit haskell-cabal
@@ -26,8 +26,8 @@ DEPEND=">=dev-lang/ghc-6.6
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${MY_PN}"
-# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
src_unpack() {
unpack "${A}"
- sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" "${S}/Setup.hs"
+
+ cabal-mksetup
}