summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/sablotron/sablotron-1.0.1.ebuild')
-rw-r--r--app-text/sablotron/sablotron-1.0.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-text/sablotron/sablotron-1.0.1.ebuild b/app-text/sablotron/sablotron-1.0.1.ebuild
index 1e66f2d4d87e..57fa6d408ddf 100644
--- a/app-text/sablotron/sablotron-1.0.1.ebuild
+++ b/app-text/sablotron/sablotron-1.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.1.ebuild,v 1.2 2004/04/01 20:54:17 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.1.ebuild,v 1.3 2004/05/03 08:08:55 kumba Exp $
-inherit libtool
+inherit libtool gnuconfig
MY_PN="Sablot"
MY_P="${MY_PN}-${PV}"
@@ -16,7 +16,7 @@ LICENSE="MPL-1.1"
SLOT="0"
IUSE="doc perl"
-KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha ~amd64 ~ia64 s390"
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~hppa ~alpha ~amd64 ~ia64 s390"
DEPEND=">=dev-libs/expat-1.95.6-r1
>=dev-perl/XML-Parser-2.3"
@@ -27,6 +27,9 @@ src_compile() {
local myconf=
+ # Detect mips systems properly
+ use mips && gnuconfig_update
+
# Please do not remove, else we get references to PORTAGE_TMPDIR
# in /usr/lib/libsablot.la ...
elibtoolize