summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/coq/coq-8.0_beta.ebuild')
-rw-r--r--app-sci/coq/coq-8.0_beta.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-sci/coq/coq-8.0_beta.ebuild b/app-sci/coq/coq-8.0_beta.ebuild
deleted file mode 100644
index 5ffb6a2ba93f..000000000000
--- a/app-sci/coq/coq-8.0_beta.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/coq/coq-8.0_beta.ebuild,v 1.2 2004/06/24 21:56:14 agriffis Exp $
-
-IUSE="norealanalysis debug"
-
-DESCRIPTION="Coq is a proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${PV/_/}/${P/_/}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-
-DEPEND=">=dev-lang/ocaml-3.06"
-
-S="${WORKDIR}/${P/_/}"
-
-src_compile() {
- local myconf="--prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/lib/coq \
- --mandir /usr/man \
- --emacslib /usr/share/emacs/site-lisp"
-
- use debug && myconf="--debug $myconf"
- use norealanalysis && myconf="$myconf --reals"
- use norealanalysis || myconf="$myconf --reals all"
-
- ./configure $myconf || die
-
- emake world || die
-}
-
-src_install() {
- make COQINSTALLPREFIX=${D} install || die
- dodoc README CREDITS CHANGES LICENSE
-}