summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/ChangeLog8
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.6.61
-rw-r--r--app-office/gnucash/gnucash-1.6.6.ebuild58
3 files changed, 66 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index e7bc7fd8bf69..78010a005966 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.1 2002/02/01 21:53:09 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.2 2002/03/28 09:07:16 seemant Exp $
+
+*gnucash-1.6.6 (28 Mar 2002)
+
+ 28 Mar 2002; Seemant Kulleen <seemant@gentoo.org> gnucash-1.6.6.ebuild :
+
+ Version bump
*gnucash-1.6.5-r1 (1 Feb 2002)
diff --git a/app-office/gnucash/files/digest-gnucash-1.6.6 b/app-office/gnucash/files/digest-gnucash-1.6.6
new file mode 100644
index 000000000000..58d55d3e6dd2
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.6.6
@@ -0,0 +1 @@
+MD5 f934bae9a81524502f8bbfa360c0b879 gnucash-1.6.6.tar.gz 14182135
diff --git a/app-office/gnucash/gnucash-1.6.6.ebuild b/app-office/gnucash/gnucash-1.6.6.ebuild
new file mode 100644
index 000000000000..d899a753b82e
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.6.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.6.6.ebuild,v 1.1 2002/03/28 09:07:16 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A personal finance manager"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gnucash.sourceforge.net"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.10
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-base/gnome-print-0.30
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.1.5
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/guile
+ cp argv-list-converters.c argv-list-converters.c.old
+ sed -e "s,printf,g_print,g" \
+ argv-list-converters.c.old > argv-list-converters.c
+ rm argv-list-converters.c.old
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ $myconf || die
+
+ make || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+
+}
+