summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 0c4711942b2b..4ace117b4d68 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.158 2013/12/01 09:45:09 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.159 2013/12/16 00:28:21 tetromino Exp $
EAPI="5"
@@ -23,8 +23,8 @@ else
fi
GV="2.24"
-MV="0.0.8"
-PULSE_PATCHES="winepulse-patches-1.7.4"
+MV="4.5.2"
+PULSE_PATCHES="winepulse-patches-1.7.8"
WINE_GENTOO="wine-gentoo-2013.06.24"
DESCRIPTION="Free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
@@ -39,8 +39,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa oss +perl +png +prelink +realtime +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
-[[ ${PV} == "9999" ]] || IUSE="${IUSE} pulseaudio"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl +png +prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype +udisks v4l +X xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
elibc_glibc? ( threads )
@@ -80,17 +79,17 @@ NATIVE_DEPEND="
ldap? ( net-nds/openldap:= )
lcms? ( media-libs/lcms:2= )
mp3? ( >=media-sound/mpg123-1.5.0 )
+ netapi? ( net-fs/samba[netapi(+)] )
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC:= )
osmesa? ( media-libs/mesa[osmesa] )
+ pulseaudio? ( media-sound/pulseaudio )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
scanner? ( media-gfx/sane-backends:= )
ssl? ( net-libs/gnutls:= )
png? ( media-libs/libpng:0= )
v4l? ( media-libs/libv4l )
xcomposite? ( x11-libs/libXcomposite )"
-[[ ${PV} == "9999" ]] || NATIVE_DEPEND="${NATIVE_DEPEND}
- pulseaudio? ( media-sound/pulseaudio )"
COMMON_DEPEND="
!amd64? ( ${NATIVE_DEPEND} )
@@ -105,7 +104,10 @@ COMMON_DEPEND="
app-emulation/emul-linux-x86-baselibs[development]
sys-libs/ncurses[abi_x86_32]
) )
- udisks? ( >=app-emulation/emul-linux-x86-baselibs-20130224[development] )
+ udisks? ( || (
+ >=app-emulation/emul-linux-x86-baselibs-20130224[development]
+ sys-apps/dbus[abi_x86_32]
+ ) )
fontconfig? ( || (
app-emulation/emul-linux-x86-xlibs[development]
media-libs/fontconfig[abi_x86_32]
@@ -257,7 +259,7 @@ src_unpack() {
unpack ${MY_P}.tar.bz2
fi
- unpack "${PULSE_PATCHES}.tar.bz2"
+ use pulseaudio && unpack "${PULSE_PATCHES}.tar.bz2"
unpack "${WINE_GENTOO}.tar.bz2"
l10n_find_plocales_changes "${S}/po" "" ".po"
@@ -271,7 +273,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.7.2-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
)
- [[ ${PV} == "9999" ]] || PATCHES+=(
+ use pulseaudio && PATCHES+=(
"../${PULSE_PATCHES}"/*.patch #421365
)
@@ -299,7 +301,11 @@ do_configure() {
if [[ ${ABI} == amd64 ]]; then
myeconfargs+=( --enable-win64 )
else
- myeconfargs+=( --disable-win64 )
+ # We currently don't have 32-bit libnetapi on amd64; #494394
+ myeconfargs+=(
+ --without-netapi
+ --disable-win64
+ )
fi
# Note: using --with-wine64 results in problems with multilib.eclass
@@ -330,6 +336,7 @@ src_configure() {
$(use_with jpeg)
$(use_with ldap)
$(use_with mp3 mpg123)
+ $(use_with netapi)
$(use_with nls gettext)
$(use_with openal)
$(use_with opencl)
@@ -349,7 +356,7 @@ src_configure() {
$(use_with xml xslt)
)
- [[ ${PV} == "9999" ]] || myeconfargs+=( $(use_with pulseaudio pulse) )
+ use pulseaudio && myeconfargs+=( --with-pulse )
if use amd64 && use abi_x86_32; then
# Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038