summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gnupg/gnupg-1.9.14.ebuild')
-rw-r--r--app-crypt/gnupg/gnupg-1.9.14.ebuild37
1 files changed, 34 insertions, 3 deletions
diff --git a/app-crypt/gnupg/gnupg-1.9.14.ebuild b/app-crypt/gnupg/gnupg-1.9.14.ebuild
index 6775888df2ee..5a206f23d5de 100644
--- a/app-crypt/gnupg/gnupg-1.9.14.ebuild
+++ b/app-crypt/gnupg/gnupg-1.9.14.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.14.ebuild,v 1.2 2005/01/06 10:55:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.14.ebuild,v 1.3 2005/01/15 01:08:46 dragonheart Exp $
inherit eutils flag-o-matic
DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/${P}.tar.gz"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/${P}.tar.gz
+ idea? ( ftp://ftp.gnupg.dk/pub/contrib-dk/idea.c.gz )"
LICENSE="GPL-2 idea? ( IDEA )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="X caps ldap nls smartcard static"
+IUSE="X caps ldap nls smartcard static idea"
RDEPEND="
!static? (
@@ -40,6 +41,16 @@ DEPEND="caps? ( sys-libs/libcap )
dev-lang/perl
dev-libs/pth"
+src_unpack() {
+ unpack ${A}
+ # Please read http://www.gnupg.org/why-not-idea.html
+ if use idea; then
+ mv ${WORKDIR}/idea.c ${S}/cipher/idea.c || \
+ ewarn "failed to insert IDEA module"
+ fi
+ sed -i -e 's/PIC/__PIC__/g' ${S}/intl/relocatable.c
+}
+
src_compile() {
local myconf=""
@@ -89,6 +100,22 @@ pkg_postinst() {
einfo "This is needed in order to have a secure place to store your"
einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
fi
+ if use idea; then
+ einfo "you have compiled ${PN} with support for the IDEA algorithm, this code"
+ einfo "is distributed under the GPL in countries where it is permitted to do so"
+ einfo "by law."
+ einfo
+ einfo "Please read http://www.gnupg.org/why-not-idea.html for more information."
+ einfo
+ einfo "If you are in a country where the IDEA algorithm is patented, you are permitted"
+ einfo "to use it at no cost for 'non revenue generating data transfer between private"
+ einfo "individuals'."
+ einfo
+ einfo "Countries where the patent applies are listed here"
+ einfo "http://www.mediacrypt.com/engl/Content/patent_info.htm"
+ einfo
+ einfo "Further information and other licenses are availble from http://www.mediacrypt.com/"
+ fi
echo
ewarn "** WARNING ** WARNING ** WARNING ** WARNING ** WARNING ** WARNING **"
ewarn " THIS IS _ALPHA_ CODE, IT MAY NOT WORK CORRECTLY OR AT ALL. THERE"
@@ -103,4 +130,8 @@ pkg_postinst() {
ewarn "** WARNING ** WARNING ** WARNING ** WARNING ** WARNING ** WARNING **"
einfo "gpg-agent is now provided in app-crypt/gpg-agent"
+
+ einfo ""
+ einfo "See http://www.gentoo.org/doc/en/gnupg-user.xml for documentation on gnupg"
+ einfo ""
}