summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/pdns/Manifest5
-rw-r--r--net-dns/pdns/files/digest-pdns-2.9.121
-rw-r--r--net-dns/pdns/metadata.xml9
-rw-r--r--net-dns/pdns/pdns-2.9.12.ebuild41
4 files changed, 54 insertions, 2 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 22648ffc19f0..4a3cd2aa29a5 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,6 +1,7 @@
MD5 820d957f19bc40f0cef9722ff9dfb986 pdns-2.9.8.ebuild 970
-MD5 5fb0d09291a2414913463a4f3658c320 ChangeLog 499
-MD5 820d957f19bc40f0cef9722ff9dfb986 pdns-2.9.12.ebuild 970
+MD5 f71c33d3646cab7f4e79b40dafba3737 metadata.xml 251
+MD5 623d3ef939334ccfb77255982b3fb8f2 ChangeLog 594
+MD5 bebfcea2c714803a78776a4066293712 pdns-2.9.12.ebuild 970
MD5 edc11ac6841533c59818f2c1fb9f2a01 files/digest-pdns-2.9.8 62
MD5 0dfd77947e929c57e09b695e6c9aa4a5 files/digest-pdns-2.9.12 63
MD5 0969ab0b2776f09c9aeb74b0996c4426 files/pdns 533
diff --git a/net-dns/pdns/files/digest-pdns-2.9.12 b/net-dns/pdns/files/digest-pdns-2.9.12
new file mode 100644
index 000000000000..64e4a44309ca
--- /dev/null
+++ b/net-dns/pdns/files/digest-pdns-2.9.12
@@ -0,0 +1 @@
+MD5 c30c664b7f1c3baad4422e99c9dd1f18 pdns-2.9.12.tar.gz 719406
diff --git a/net-dns/pdns/metadata.xml b/net-dns/pdns/metadata.xml
new file mode 100644
index 000000000000..bf8504faedda
--- /dev/null
+++ b/net-dns/pdns/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jhhudso@gentoo.org</email>
+ <name>Jared Hudson</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-dns/pdns/pdns-2.9.12.ebuild b/net-dns/pdns/pdns-2.9.12.ebuild
new file mode 100644
index 000000000000..f6e5a89d31f5
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.12.ebuild,v 1.1 2003/10/30 15:20:07 jhhudso Exp $
+
+DESCRIPTION="The PowerDNS Daemon."
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="mysql static"
+
+DEPEND="virtual/glibc
+ mysql? ( >=dev-db/mysql-3.23.54a )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf=""
+ local modules=""
+
+ use static && myconf="$myconf --enable-static-binaries"
+ use mysql && modules="gmysql $modules"
+ myconf="$myconf --with-modules=$modules"
+
+ econf $myconf
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog HACKING INSTALL README TODO WARNING pdns/COPYING
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/pdns
+
+ mv ${D}/etc/pdns.conf-dist ${D}/etc/pdns.conf
+}