summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-07-22 05:58:07 +0000
committerJon Hood <squinky86@gentoo.org>2004-07-22 05:58:07 +0000
commit93b0bf4ff3fc3dce006788a4a89c1396511eb130 (patch)
tree54a08a4077efe9ff6ab8cb1dd55352667d8438e4 /net-p2p/phex
parentTook over as maintainer. Added -funroll-all-loops to filter-flag as it break... (diff)
downloadhistorical-93b0bf4ff3fc3dce006788a4a89c1396511eb130.tar.gz
historical-93b0bf4ff3fc3dce006788a4a89c1396511eb130.tar.bz2
historical-93b0bf4ff3fc3dce006788a4a89c1396511eb130.zip
Initial import.
Diffstat (limited to 'net-p2p/phex')
-rw-r--r--net-p2p/phex/ChangeLog10
-rw-r--r--net-p2p/phex/Manifest5
-rw-r--r--net-p2p/phex/files/digest-phex-2.0.0.761
-rw-r--r--net-p2p/phex/files/phex.sh7
-rw-r--r--net-p2p/phex/metadata.xml5
-rw-r--r--net-p2p/phex/phex-2.0.0.76.ebuild34
6 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/phex/ChangeLog b/net-p2p/phex/ChangeLog
new file mode 100644
index 000000000000..dd1fd3b640b8
--- /dev/null
+++ b/net-p2p/phex/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-p2p/phex
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/ChangeLog,v 1.1 2004/07/22 05:58:07 squinky86 Exp $
+
+*phex-2.0.0.76 (22 Jul 2004)
+
+ 22 Jul 2004; Jon Hood <squinky86@gentoo.org> +metadata.xml,
+ +phex-2.0.0.76.ebuild, +files/phex.sh:
+ Initial commit.
+
diff --git a/net-p2p/phex/Manifest b/net-p2p/phex/Manifest
new file mode 100644
index 000000000000..11a553e3a857
--- /dev/null
+++ b/net-p2p/phex/Manifest
@@ -0,0 +1,5 @@
+MD5 d09232d8418402499f746ac9d7e728f1 phex-2.0.0.76.ebuild 772
+MD5 332a99bc6db39cfa96d69d1e2ae1edd5 ChangeLog 352
+MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 4bdd6b068f3ef84f8c2f258a685c1c65 files/digest-phex-2.0.0.76 63
+MD5 3089ad1db7b9aaf83ddad49afa8165bc files/phex.sh 256
diff --git a/net-p2p/phex/files/digest-phex-2.0.0.76 b/net-p2p/phex/files/digest-phex-2.0.0.76
new file mode 100644
index 000000000000..aaad2c9fe194
--- /dev/null
+++ b/net-p2p/phex/files/digest-phex-2.0.0.76
@@ -0,0 +1 @@
+MD5 906650ec01b9d647b97d1fa6f3f79610 phex_2.0.0.76.zip 2120002
diff --git a/net-p2p/phex/files/phex.sh b/net-p2p/phex/files/phex.sh
new file mode 100644
index 000000000000..d0a78c29b2b8
--- /dev/null
+++ b/net-p2p/phex/files/phex.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/files/phex.sh,v 1.1 2004/07/22 05:58:07 squinky86 Exp $
+
+cd /opt/phex
+java -jar phex.jar
diff --git a/net-p2p/phex/metadata.xml b/net-p2p/phex/metadata.xml
new file mode 100644
index 000000000000..aa0f3664825f
--- /dev/null
+++ b/net-p2p/phex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>
diff --git a/net-p2p/phex/phex-2.0.0.76.ebuild b/net-p2p/phex/phex-2.0.0.76.ebuild
new file mode 100644
index 000000000000..aa077dd4ce51
--- /dev/null
+++ b/net-p2p/phex/phex-2.0.0.76.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/phex-2.0.0.76.ebuild,v 1.1 2004/07/22 05:58:07 squinky86 Exp $
+
+DESCRIPTION="java gnutella file-sharing application"
+HOMEPAGE="http://phex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/phex/${P/-/_}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=virtual/jdk-1.4
+ virtual/x11"
+S=${WORKDIR}/${P/-/_}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ echo "PATH=/opt/${PN}/bin" >> ${S}/50${PN}
+}
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins *.jar
+ exeinto /opt/${PN}/bin
+ newexe ${FILESDIR}/${PN}.sh ${PN}
+ insinto /etc/env.d
+ doins 50${PN}
+ dohtml docs/readme/*
+}