summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-01-15 02:24:42 +0000
committerDan Armak <danarmak@gentoo.org>2005-01-15 02:24:42 +0000
commit9300be3031aefac98b4fa4b0b02abec7b657d43e (patch)
treee0ca082a44a83de2d88a041ecadbb5b75f066c76 /kde-base/xparts
parent(no commit message) (diff)
downloadhistorical-9300be3031aefac98b4fa4b0b02abec7b657d43e.tar.gz
historical-9300be3031aefac98b4fa4b0b02abec7b657d43e.tar.bz2
historical-9300be3031aefac98b4fa4b0b02abec7b657d43e.zip
kde 3.4 split ebuilds, all masked
Diffstat (limited to 'kde-base/xparts')
-rw-r--r--kde-base/xparts/Manifest2
-rw-r--r--kde-base/xparts/files/digest-xparts-3.4.0_beta13
-rw-r--r--kde-base/xparts/xparts-3.4.0_beta1.ebuild37
3 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/xparts/Manifest b/kde-base/xparts/Manifest
index d015879f7de1..6e9322ebd8bb 100644
--- a/kde-base/xparts/Manifest
+++ b/kde-base/xparts/Manifest
@@ -1,5 +1,7 @@
+MD5 7d8d991ca692882ed400b665f18164a8 xparts-3.4.0_beta1.ebuild 1085
MD5 441e57ac78570dd1cec087460be7febe xparts-3.3.1.ebuild 1242
MD5 d7c481ff42f014c0dbd85b8ed7bed1c4 ChangeLog 985
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
+MD5 4877266a41162d4c439090a71dcc66bc files/digest-xparts-3.4.0_beta1 225
MD5 ffe26fb6d5d193883dfebd69250df2e5 files/no-gtk-glib-check.diff 949
MD5 70e20b1b123bf8d012966ea1675c9306 files/digest-xparts-3.3.1 222
diff --git a/kde-base/xparts/files/digest-xparts-3.4.0_beta1 b/kde-base/xparts/files/digest-xparts-3.4.0_beta1
new file mode 100644
index 000000000000..1d0086ae2535
--- /dev/null
+++ b/kde-base/xparts/files/digest-xparts-3.4.0_beta1
@@ -0,0 +1,3 @@
+MD5 5c5d32448f4b473201d72613cc2902b5 kdebindings-3.3.90.tar.bz2 7113177
+MD5 06b5bb329c3d7271a36dddd17591c259 kdebindings-3.3.90-3.3.91.tar.xdelta 699870
+MD5 168cc78368bd9adf23a348ab24ea9dde kdebindings-3.3.91.tar.bz2 7076147
diff --git a/kde-base/xparts/xparts-3.4.0_beta1.ebuild b/kde-base/xparts/xparts-3.4.0_beta1.ebuild
new file mode 100644
index 000000000000..8a90c07ce4de
--- /dev/null
+++ b/kde-base/xparts/xparts-3.4.0_beta1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/xparts-3.4.0_beta1.ebuild,v 1.1 2005/01/15 02:24:42 danarmak Exp $
+
+KMNAME=kdebindings
+KMEXTRACTONLY="dcopc"
+KMCOPYLIB="libdcopc dcopc"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Allows embedding of generic XParts as KDE KParts"
+KEYWORDS="-*" # broken according to upstream - 3.4a1 README
+IUSE="mozilla"
+DEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ mozilla? ( net-www/mozilla )"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ # Doesn't affect makefile tarballs.
+ # Real solution will be to split this further and make a separate
+ # ebuild for the mozilla xpart.
+ # But since this is officially broken anyway I'm not going to bother...
+ if ! useq mozilla ; then
+ # disable mozilla bindings/xpart, because configure doesn't seem to do so
+ # even when it doesn't detect the mozilla headers
+ cd ${S}/xparts
+ cp Makefile.am Makefile.am.orig
+ sed -e 's:mozilla::' Makefile.am.orig > Makefile.am
+ fi
+ cd ${S} && make -f admin/Makefile.common
+}
+