summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-09-02 08:23:30 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-09-02 08:23:30 +0000
commitfb6e8b4ca7aef98ddb274c6e7c633e70eac95d75 (patch)
tree214c88d748d7bc80061fde4a4a2ae6705d8e285e /eclass
parentVersion bump, closes bug #104510 (diff)
downloadhistorical-fb6e8b4ca7aef98ddb274c6e7c633e70eac95d75.tar.gz
historical-fb6e8b4ca7aef98ddb274c6e7c633e70eac95d75.tar.bz2
historical-fb6e8b4ca7aef98ddb274c6e7c633e70eac95d75.zip
Add --automake to libtoolize if we are using automake.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass9
1 files changed, 7 insertions, 2 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 6ae51884fbd3..ea6dbe043190 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.18 2005/08/31 20:17:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.19 2005/09/02 08:23:30 azarah Exp $
#
# Author: Diego Pettenò <flameeyes@gentoo.org>
# Enhancements: Martin Schlemmer <azarah@gentoo.org>
@@ -104,10 +104,15 @@ eaclocal() {
}
_elibtoolize() {
+ local opts
+
# Check if we should run libtoolize
[[ -n $(autotools_check_macro "AC_PROG_LIBTOOL") ]] || return 0
+
+ [[ -f Makefile.am ]] && opts="--automake"
+
[[ "${USERLAND}" == "Darwin" ]] && LIBTOOLIZE="glibtoolize"
- autotools_run_tool ${LIBTOOLIZE:-libtoolize} "$@"
+ autotools_run_tool ${LIBTOOLIZE:-libtoolize} "$@" ${opts}
# Need to rerun aclocal
eaclocal