summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-25 09:38:36 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-25 09:38:36 +0000
commit78276801a5f4d0ee0c51497c38eb7679c5518b4a (patch)
tree26fdd30d6e2c75fb1d9d0045b5989213f878d4de /dev-ml
parentfixed description (diff)
downloadhistorical-78276801a5f4d0ee0c51497c38eb7679c5518b4a.tar.gz
historical-78276801a5f4d0ee0c51497c38eb7679c5518b4a.tar.bz2
historical-78276801a5f4d0ee0c51497c38eb7679c5518b4a.zip
fix for some rare dependency mismatch.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgl/ChangeLog13
-rw-r--r--dev-ml/lablgl/lablgl-0.98.ebuild24
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index d1791037367b..ec36b2cc7277 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,9 +1,20 @@
# ChangeLog for dev-ml/lablgl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.2 2002/09/03 17:46:02 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.3 2002/10/25 09:38:36 george Exp $
*lablgl-0.98.ebuild (03 Sep 2002)
+ 24 Oct 2002; George Shapovalov <george@gentoo.org> lablgl-0.98.ebuild :
+
+ lablgl requires ocaml compiled with tk support. Ocaml has tk as an optional dependency.
+ Added some code to pkg_setup to detect if the tcltk USE var is set and abort if not with the message
+ asking user to emerge ocaml with tk support.
+ See bug #8126 for details. Thanks to Sami Nieminen <sami.nieminen@iki.fi> for report and
+ Jeffrey Palmer <jeffrey.palmer.acm.org> for dependency tracing and diagnostics.
+
+ The above hack is goinmg to only catch 95% of situations. The real fix involves modifications to portage
+ to make it correctly process optional dependencies of dependencies. See bug #2272 for details.
+
03 Sep 2002; G Shapovalov <george@gentoo.org> lablgl-0.98.ebuild, files/{LablGL-0.98-Makefile-destdir.patch,LablGL-0.98-Makefile.config,digest-lablgl-0.98} :
updated to 0.98. This fixes some build failures with ocaml-3.06.
diff --git a/dev-ml/lablgl/lablgl-0.98.ebuild b/dev-ml/lablgl/lablgl-0.98.ebuild
index 57c47b932043..ed7347e2500a 100644
--- a/dev-ml/lablgl/lablgl-0.98.ebuild
+++ b/dev-ml/lablgl/lablgl-0.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-0.98.ebuild,v 1.3 2002/10/20 18:42:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-0.98.ebuild,v 1.4 2002/10/25 09:38:36 george Exp $
IUSE="opengl"
@@ -20,6 +20,28 @@ KEYWORDS="x86"
#(anyway package uses mixture of upper and lower case letters)
Name="LablGL"
+pkg_setup() {
+ #lablgl requires ocaml compiled with tk support while ocaml has it as an optional dependency
+ #need to do some checks and correct situation as if necessary
+
+ if ! use tcltk; then
+ einfo "#######################################################"
+ einfo ""
+ einfo "ebuild detected that tcltk USE flag is not defined"
+ einfo "lablgl requires ocaml built with tk support!!! "
+ einfo ""
+ einfo "Please make sure that ocaml is emerged with tk support: "
+ einfo 'USE="tcltk" emerge ocaml'
+ einfo "or even better add tcltk to you USE definition in make.conf"
+ einfo ""
+ einfo "#######################################################"
+
+ false;
+ else
+ echo "found tcltk USE flag, proceeding normally!"
+ fi
+}
+
src_unpack() {
unpack ${A}