From c7b15e28f5bdc399b564c5017350b8083ce0623b Mon Sep 17 00:00:00 2001
From: "Anthony G. Basile" <blueness@gentoo.org>
Date: Wed, 16 Dec 2015 12:10:06 -0500
Subject: net-p2p/litecoin-qt: fix for API change in miniunpnc, bug #567080.

Package-Manager: portage-2.2.24
---
 .../litecoin-qt/files/litecoin-miniupnpc-abi.patch |  19 +++
 net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r1.ebuild | 144 --------------------
 net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r2.ebuild | 145 +++++++++++++++++++++
 net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild    | 143 --------------------
 4 files changed, 164 insertions(+), 287 deletions(-)
 create mode 100644 net-p2p/litecoin-qt/files/litecoin-miniupnpc-abi.patch
 delete mode 100644 net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r1.ebuild
 create mode 100644 net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r2.ebuild
 delete mode 100644 net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild

(limited to 'net-p2p/litecoin-qt')

diff --git a/net-p2p/litecoin-qt/files/litecoin-miniupnpc-abi.patch b/net-p2p/litecoin-qt/files/litecoin-miniupnpc-abi.patch
new file mode 100644
index 000000000000..7315ea9d2a45
--- /dev/null
+++ b/net-p2p/litecoin-qt/files/litecoin-miniupnpc-abi.patch
@@ -0,0 +1,19 @@
+diff -Nuar litecoin-0.10.2.2/src/net.cpp litecoin-0.10.2.2-fix/src/net.cpp
+--- litecoin-0.10.2.2/src/net.cpp	2015-06-15 08:51:30.000000000 +0000
++++ litecoin-0.10.2.2-fix/src/net.cpp	2015-12-16 12:38:52.881533970 +0000
+@@ -1020,10 +1020,14 @@
+ #ifndef UPNPDISCOVER_SUCCESS
+     /* miniupnpc 1.5 */
+     devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
+-#else
++#elif MINIUPNPC_API_VERSION < 14
+     /* miniupnpc 1.6 */
+     int error = 0;
+     devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
++#else
++   /* miniupnpc 1.9.20150730 */
++   int error = 0;
++   devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 2, &error);
+ #endif
+ 
+     struct UPNPUrls urls;
\ No newline at end of file
diff --git a/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r1.ebuild b/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r1.ebuild
deleted file mode 100644
index 6c2056b3707a..000000000000
--- a/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r1.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-DB_VER="4.8"
-
-LANGS="ach af_ZA ar be_BY bg bs ca_ES ca ca@valencia cmn cs cy da de el_GR en eo es_CL es_DO es_MX es es_UY et eu_ES fa_IR fa fi fr_CA fr gl gu_IN he hi_IN hr hu id_ID it ja ka kk_KZ ko_KR ky la lt lv_LV mn ms_MY nb nl pam pl pt_BR pt_PT ro_RO ru sah sk sl_SI sq sr sv th_TH tr uk ur_PK uz@Cyrl vi vi_VN zh_CN zh_HK zh_TW"
-
-inherit autotools db-use eutils fdo-mime gnome2-utils kde4-functions qt4-r2
-
-MyPV="${PV/_/-}"
-MyPN="litecoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine"
-HOMEPAGE="https://litecoin.org/"
-SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
-
-LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain || ( CC-BY-SA-3.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dbus kde +qrcode qt5 upnp"
-
-RDEPEND="
-	dev-libs/boost[threads(+)]
-	dev-libs/openssl:0[-bindist]
-	dev-libs/protobuf:=
-	qrcode? (
-		media-gfx/qrencode
-	)
-	upnp? (
-		net-libs/miniupnpc
-	)
-	sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-	>=dev-libs/leveldb-1.18-r1
-	!qt5? (
-		dev-qt/qtgui:4
-		dbus? (
-			dev-qt/qtdbus:4
-		)
-	)
-	qt5? (
-		dev-qt/qtgui:5
-		dbus? (
-			dev-qt/qtdbus:5
-		)
-	)
-"
-DEPEND="${RDEPEND}
-	>=app-shells/bash-4.1
-"
-
-DOCS="doc/README.md doc/release-notes.md"
-
-S="${WORKDIR}/${MyP}"
-
-src_prepare() {
-	epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
-	epatch "${FILESDIR}/litecoind-0.10.2.2-memenv_h.patch"
-	eautoreconf
-	rm -r src/leveldb
-
-	cd src || die
-
-	local filt= yeslang= nolang=
-
-	for lan in $LANGS; do
-		if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
-			ewarn "Language '$lan' no longer supported. Ebuild needs update."
-		fi
-	done
-
-	for ts in $(ls qt/locale/*.ts)
-	do
-		x="${ts/*bitcoin_/}"
-		x="${x/.ts/}"
-		if ! use "linguas_$x"; then
-			nolang="$nolang $x"
-			#rm "$ts"
-			filt="$filt\\|$x"
-		else
-			yeslang="$yeslang $x"
-		fi
-	done
-
-	filt="bitcoin_\\(${filt:2}\\)\\.\(qm\|ts\)"
-	sed "/${filt}/d" -i 'qt/bitcoin_locale.qrc'
-	einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
-}
-
-src_configure() {
-	local my_econf=
-	if use upnp; then
-		my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
-	else
-		my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
-	fi
-	econf \
-		--enable-wallet \
-		--disable-ccache \
-		--disable-static \
-		--disable-tests \
-		--with-system-leveldb \
-		--with-system-libsecp256k1  \
-		--without-libs \
-		--without-utils \
-		--without-daemon  \
-        --with-gui=$(usex qt5 qt5 qt4) \
-        $(use_with dbus qtdbus)  \
-        $(use_with qrcode qrencode)  \
-		${my_econf}
-}
-
-src_install() {
-	default
-
-	insinto /usr/share/pixmaps
-	newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
-
-	make_desktop_entry "${PN} %u" "Litecoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Qt;Network;P2P;Office;Finance;" "MimeType=x-scheme-handler/litecoin;\nTerminal=false"
-
-	newman contrib/debian/manpages/bitcoin-qt.1 ${PN}.1
-
-	if use kde; then
-		insinto /usr/share/kde4/services
-		newins contrib/debian/bitcoin-qt.protocol ${PN}.protocol
-	fi
-}
-
-update_caches() {
-	gnome2_icon_cache_update
-	fdo-mime_desktop_database_update
-	buildsycoca
-}
-
-pkg_postinst() {
-	update_caches
-}
-
-pkg_postrm() {
-	update_caches
-}
diff --git a/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r2.ebuild b/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r2.ebuild
new file mode 100644
index 000000000000..49c5cacd64bf
--- /dev/null
+++ b/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2-r2.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DB_VER="4.8"
+
+LANGS="ach af_ZA ar be_BY bg bs ca_ES ca ca@valencia cmn cs cy da de el_GR en eo es_CL es_DO es_MX es es_UY et eu_ES fa_IR fa fi fr_CA fr gl gu_IN he hi_IN hr hu id_ID it ja ka kk_KZ ko_KR ky la lt lv_LV mn ms_MY nb nl pam pl pt_BR pt_PT ro_RO ru sah sk sl_SI sq sr sv th_TH tr uk ur_PK uz@Cyrl vi vi_VN zh_CN zh_HK zh_TW"
+
+inherit autotools db-use eutils fdo-mime gnome2-utils kde4-functions qt4-r2
+
+MyPV="${PV/_/-}"
+MyPN="litecoin"
+MyP="${MyPN}-${MyPV}"
+
+DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine"
+HOMEPAGE="https://litecoin.org/"
+SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
+
+LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain || ( CC-BY-SA-3.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus kde +qrcode qt5 upnp"
+
+RDEPEND="
+	dev-libs/boost[threads(+)]
+	dev-libs/openssl:0[-bindist]
+	dev-libs/protobuf:=
+	qrcode? (
+		media-gfx/qrencode
+	)
+	upnp? (
+		net-libs/miniupnpc
+	)
+	sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+	>=dev-libs/leveldb-1.18-r1
+	!qt5? (
+		dev-qt/qtgui:4
+		dbus? (
+			dev-qt/qtdbus:4
+		)
+	)
+	qt5? (
+		dev-qt/qtgui:5
+		dbus? (
+			dev-qt/qtdbus:5
+		)
+	)
+"
+DEPEND="${RDEPEND}
+	>=app-shells/bash-4.1
+"
+
+DOCS="doc/README.md doc/release-notes.md"
+
+S="${WORKDIR}/${MyP}"
+
+src_prepare() {
+	epatch "${FILESDIR}"/0.9.0-sys_leveldb.patch
+	epatch "${FILESDIR}"/litecoind-0.10.2.2-memenv_h.patch
+	epatch "${FILESDIR}"/litecoin-miniupnpc-abi.patch
+	eautoreconf
+	rm -r src/leveldb
+
+	cd src || die
+
+	local filt= yeslang= nolang=
+
+	for lan in $LANGS; do
+		if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
+			ewarn "Language '$lan' no longer supported. Ebuild needs update."
+		fi
+	done
+
+	for ts in $(ls qt/locale/*.ts)
+	do
+		x="${ts/*bitcoin_/}"
+		x="${x/.ts/}"
+		if ! use "linguas_$x"; then
+			nolang="$nolang $x"
+			#rm "$ts"
+			filt="$filt\\|$x"
+		else
+			yeslang="$yeslang $x"
+		fi
+	done
+
+	filt="bitcoin_\\(${filt:2}\\)\\.\(qm\|ts\)"
+	sed "/${filt}/d" -i 'qt/bitcoin_locale.qrc'
+	einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
+}
+
+src_configure() {
+	local my_econf=
+	if use upnp; then
+		my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
+	else
+		my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
+	fi
+	econf \
+		--enable-wallet \
+		--disable-ccache \
+		--disable-static \
+		--disable-tests \
+		--with-system-leveldb \
+		--with-system-libsecp256k1  \
+		--without-libs \
+		--without-utils \
+		--without-daemon  \
+		--with-gui=$(usex qt5 qt5 qt4) \
+		$(use_with dbus qtdbus)  \
+		$(use_with qrcode qrencode)  \
+		${my_econf}
+}
+
+src_install() {
+	default
+
+	insinto /usr/share/pixmaps
+	newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
+
+	make_desktop_entry "${PN} %u" "Litecoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Qt;Network;P2P;Office;Finance;" "MimeType=x-scheme-handler/litecoin;\nTerminal=false"
+
+	newman contrib/debian/manpages/bitcoin-qt.1 ${PN}.1
+
+	if use kde; then
+		insinto /usr/share/kde4/services
+		newins contrib/debian/bitcoin-qt.protocol ${PN}.protocol
+	fi
+}
+
+update_caches() {
+	gnome2_icon_cache_update
+	fdo-mime_desktop_database_update
+	buildsycoca
+}
+
+pkg_postinst() {
+	update_caches
+}
+
+pkg_postrm() {
+	update_caches
+}
diff --git a/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild b/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild
deleted file mode 100644
index 2d33a74757f8..000000000000
--- a/net-p2p/litecoin-qt/litecoin-qt-0.10.2.2.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-DB_VER="4.8"
-
-LANGS="ach af_ZA ar be_BY bg bs ca_ES ca ca@valencia cmn cs cy da de el_GR en eo es_CL es_DO es_MX es es_UY et eu_ES fa_IR fa fi fr_CA fr gl gu_IN he hi_IN hr hu id_ID it ja ka kk_KZ ko_KR ky la lt lv_LV mn ms_MY nb nl pam pl pt_BR pt_PT ro_RO ru sah sk sl_SI sq sr sv th_TH tr uk ur_PK uz@Cyrl vi vi_VN zh_CN zh_HK zh_TW"
-
-inherit autotools db-use eutils fdo-mime gnome2-utils kde4-functions qt4-r2
-
-MyPV="${PV/_/-}"
-MyPN="litecoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine"
-HOMEPAGE="https://litecoin.org/"
-SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
-
-LICENSE="MIT ISC GPL-3 LGPL-2.1 public-domain || ( CC-BY-SA-3.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dbus kde +qrcode qt5 upnp"
-
-RDEPEND="
-	dev-libs/boost[threads(+)]
-	dev-libs/openssl:0[-bindist]
-	dev-libs/protobuf:=
-	qrcode? (
-		media-gfx/qrencode
-	)
-	upnp? (
-		net-libs/miniupnpc
-	)
-	sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
-	<=dev-libs/leveldb-1.15.0-r1
-	!qt5? (
-		dev-qt/qtgui:4
-		dbus? (
-			dev-qt/qtdbus:4
-		)
-	)
-	qt5? (
-		dev-qt/qtgui:5
-		dbus? (
-			dev-qt/qtdbus:5
-		)
-	)
-"
-DEPEND="${RDEPEND}
-	>=app-shells/bash-4.1
-"
-
-DOCS="doc/README.md doc/release-notes.md"
-
-S="${WORKDIR}/${MyP}"
-
-src_prepare() {
-	epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
-	eautoreconf
-	rm -r src/leveldb
-
-	cd src || die
-
-	local filt= yeslang= nolang=
-
-	for lan in $LANGS; do
-		if [ ! -e qt/locale/bitcoin_$lan.ts ]; then
-			ewarn "Language '$lan' no longer supported. Ebuild needs update."
-		fi
-	done
-
-	for ts in $(ls qt/locale/*.ts)
-	do
-		x="${ts/*bitcoin_/}"
-		x="${x/.ts/}"
-		if ! use "linguas_$x"; then
-			nolang="$nolang $x"
-			#rm "$ts"
-			filt="$filt\\|$x"
-		else
-			yeslang="$yeslang $x"
-		fi
-	done
-
-	filt="bitcoin_\\(${filt:2}\\)\\.\(qm\|ts\)"
-	sed "/${filt}/d" -i 'qt/bitcoin_locale.qrc'
-	einfo "Languages -- Enabled:$yeslang -- Disabled:$nolang"
-}
-
-src_configure() {
-	local my_econf=
-	if use upnp; then
-		my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
-	else
-		my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
-	fi
-	econf \
-		--enable-wallet \
-		--disable-ccache \
-		--disable-static \
-		--disable-tests \
-		--with-system-leveldb \
-		--with-system-libsecp256k1  \
-		--without-libs \
-		--without-utils \
-		--without-daemon  \
-        --with-gui=$(usex qt5 qt5 qt4) \
-        $(use_with dbus qtdbus)  \
-        $(use_with qrcode qrencode)  \
-		${my_econf}
-}
-
-src_install() {
-	default
-
-	insinto /usr/share/pixmaps
-	newins "share/pixmaps/bitcoin.ico" "${PN}.ico"
-
-	make_desktop_entry "${PN} %u" "Litecoin-Qt" "/usr/share/pixmaps/${PN}.ico" "Qt;Network;P2P;Office;Finance;" "MimeType=x-scheme-handler/litecoin;\nTerminal=false"
-
-	newman contrib/debian/manpages/bitcoin-qt.1 ${PN}.1
-
-	if use kde; then
-		insinto /usr/share/kde4/services
-		newins contrib/debian/bitcoin-qt.protocol ${PN}.protocol
-	fi
-}
-
-update_caches() {
-	gnome2_icon_cache_update
-	fdo-mime_desktop_database_update
-	buildsycoca
-}
-
-pkg_postinst() {
-	update_caches
-}
-
-pkg_postrm() {
-	update_caches
-}
-- 
cgit v1.2.3-65-gdbad