From eb92a576ec84dc783d578527c28aaa869d67fdae Mon Sep 17 00:00:00 2001
From: Matthew Thode <prometheanfire@gentoo.org>
Date: Sat, 13 Nov 2021 20:23:45 -0600
Subject: net-analyzer/icinga2: 2.13.2 bump

Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
---
 net-analyzer/icinga2/Manifest              |   1 +
 net-analyzer/icinga2/icinga2-2.13.2.ebuild | 147 +++++++++++++++++++++++++++++
 2 files changed, 148 insertions(+)
 create mode 100644 net-analyzer/icinga2/icinga2-2.13.2.ebuild

(limited to 'net-analyzer')

diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index e62b0f3dde8b..4365b10d153a 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1 +1,2 @@
 DIST icinga2-2.13.1.tar.gz 7585070 BLAKE2B 5a81d627728f8afb0c19761972d45606db246c132dfeb92d2fb32479631add8aaeb1d0dea66f354d3638ca346a3e8bcc266e8397e5246f984566f75c2b5e8003 SHA512 450df3ee36457006c78ca244331d111f65642ba5e232be28e60f189de998f5bb8ed70f2e1d46ea61374ae7bd6a5cf950e487bada1c7af7064970a149cc86baa7
+DIST icinga2-2.13.2.tar.gz 7589357 BLAKE2B 6e1ba570e0286f09f37b3cea3b1cd833fd3005c5788e24b750edb100346c46958e97ed5df05947dc47c2bbf856cc6090d661e741072f473b8308aee5e1c0e94e SHA512 39a6f996bca671a2a22fc04e5995714b874e027888a7c9e479d5b526b23104915b7f99afb1220d440af482013043e5b969b0a0145041ac55009d1a81053e2906
diff --git a/net-analyzer/icinga2/icinga2-2.13.2.ebuild b/net-analyzer/icinga2/icinga2-2.13.2.ebuild
new file mode 100644
index 000000000000..de80eb55dfc4
--- /dev/null
+++ b/net-analyzer/icinga2/icinga2-2.13.2.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake systemd
+
+if [[ ${PV} != 9999 ]]; then
+	SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~arm64 ~x86"
+else
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
+fi
+
+DESCRIPTION="Distributed, general purpose, network monitoring engine"
+HOMEPAGE="https://icinga.com/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="console jumbo-build lto mail mariadb minimal +mysql nano-syntax +plugins postgres systemd +vim-syntax"
+
+# Add accounts to DEPEND because of fowners in src_install
+DEPEND="
+	dev-libs/openssl:0=
+	>=dev-libs/boost-1.66.0:=[context]
+	console? ( dev-libs/libedit )
+	mariadb? ( dev-db/mariadb-connector-c:= )
+	mysql? ( dev-db/mysql-connector-c:= )
+	postgres? ( dev-db/postgresql:= )
+	dev-libs/yajl:=
+	acct-user/icinga
+	acct-group/icinga
+	acct-group/icingacmd"
+BDEPEND="
+	sys-devel/bison
+	>=sys-devel/flex-2.5.35"
+RDEPEND="
+	${DEPEND}
+	plugins? ( || (
+		net-analyzer/monitoring-plugins
+		net-analyzer/nagios-plugins
+	) )
+	mail? ( virtual/mailx )
+	acct-group/nagios"
+
+REQUIRED_USE="!minimal? ( || ( mariadb mysql postgres ) )"
+
+PATCHES=(
+	# https://github.com/Icinga/icinga2/issues/8185#issuecomment-680875875
+)
+
+src_configure() {
+	local mycmakeargs=(
+		-DICINGA2_UNITY_BUILD=$(usex jumbo-build)
+		-DCMAKE_INSTALL_SYSCONFDIR=/etc
+		-DCMAKE_INSTALL_LOCALSTATEDIR=/var
+		-DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
+		-DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
+		-DICINGA2_USER=icinga
+		-DICINGA2_GROUP=icingacmd
+		-DICINGA2_COMMAND_GROUP=icingacmd
+		-DICINGA2_RUNDIR=/run
+		-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=ON
+		-DUSE_SYSTEMD=$(usex systemd)
+		-DLOGROTATE_HAS_SU=ON
+		-DICINGA2_LTO_BUILD=$(usex lto)
+	)
+	# default to off if minimal, allow the flags to be set otherwise
+	if use minimal; then
+		mycmakeargs+=(
+			-DICINGA2_WITH_MYSQL=OFF
+			-DICINGA2_WITH_PGSQL=OFF
+		)
+	else
+		mycmakeargs+=(
+			-DICINGA2_WITH_PGSQL=$(usex postgres)
+			-DICINGA2_WITH_MYSQL=$(usex mysql yes $(usex mariadb))
+		)
+	fi
+
+	cmake_src_configure
+}
+
+src_install() {
+	cmake_src_install
+
+	newinitd "${FILESDIR}"/icinga2.initd-3 icinga2
+
+	if use mysql || use mariadb; then
+		docinto schema
+		newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
+		docinto schema/upgrade
+		dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
+	fi
+	if use postgres; then
+		docinto schema
+		newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
+		docinto schema/upgrade
+		dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
+	fi
+
+	keepdir /etc/icinga2
+	keepdir /var/lib/icinga2/api/zones
+	keepdir /var/lib/icinga2/api/repository
+	keepdir /var/lib/icinga2/api/log
+	keepdir /var/spool/icinga2/perfdata
+
+	rm -r "${D}/run" || die "failed to remove /run"
+	rm -r "${D}/var/cache" || die "failed to remove /var/cache"
+
+	fowners root:icinga /etc/icinga2
+	fperms 0750 /etc/icinga2
+	fowners icinga:icinga /var/lib/icinga2
+	fowners icinga:icinga /var/spool/icinga2
+	fowners -R icinga:icingacmd /var/lib/icinga2/api
+	fowners icinga:icinga /var/spool/icinga2/perfdata
+	fowners icinga:icingacmd /var/log/icinga2
+
+	fperms ug+rwX,o-rwx /etc/icinga2
+	fperms ug+rwX,o-rwx /var/lib/icinga2
+	fperms ug+rwX,o-rwx /var/spool/icinga2
+	fperms ug+rwX,o-rwx /var/log/icinga2
+
+	if use vim-syntax; then
+		insinto /usr/share/vim/vimfiles
+		doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
+		doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
+	fi
+
+	if use nano-syntax; then
+		insinto /usr/share/nano
+		doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
+	fi
+}
+
+pkg_postinst() {
+	if [[ "${PV}" != 9999 ]]; then
+		local v
+		for v in ${REPLACING_VERSIONS}; do
+			if ver_test "${PV}" -gt "${v}"; then
+				elog "DB IDO schema upgrade may be required."
+				elog "https://www.icinga.com/docs/icinga2/latest/doc/16-upgrading-icinga-2/"
+			fi
+		done
+	fi
+}
-- 
cgit v1.2.3-65-gdbad