From 707c2b326431a0a3bf8b3f866b2d17d63bf1925c Mon Sep 17 00:00:00 2001
From: Marek Szuba <marecki@gentoo.org>
Date: Tue, 26 Jul 2022 09:46:19 +0100
Subject: app-text/bibletime: move dev-libs/icu back to DEPEND-only

Having re-examined the documentation, I did get it right the first time
- ICU, Curl and zlib are *not* direct dependencies of Bibletime, upstream
build scripts simply attempts to guess what app-text/sword has been
linked against. Which incidentally may not work correctly under Gentoo
due to USE flags, will later on nuke those checks + possibly add
USE-flag propagation to SWORD.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
---
 app-text/bibletime/bibletime-3.0.3-r1.ebuild | 59 ----------------------------
 app-text/bibletime/bibletime-3.0.3-r2.ebuild | 59 ++++++++++++++++++++++++++++
 2 files changed, 59 insertions(+), 59 deletions(-)
 delete mode 100644 app-text/bibletime/bibletime-3.0.3-r1.ebuild
 create mode 100644 app-text/bibletime/bibletime-3.0.3-r2.ebuild

(limited to 'app-text/bibletime')

diff --git a/app-text/bibletime/bibletime-3.0.3-r1.ebuild b/app-text/bibletime/bibletime-3.0.3-r1.ebuild
deleted file mode 100644
index 3cb15a25d576..000000000000
--- a/app-text/bibletime/bibletime-3.0.3-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg-utils
-
-DESCRIPTION="Qt Bible-study application using the SWORD library"
-HOMEPAGE="https://bibletime.info/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=app-text/sword-1.8.1
-	dev-cpp/clucene
-	dev-libs/icu
-	dev-qt/qtcore:5
-	dev-qt/qtgui:5
-	dev-qt/qtprintsupport:5
-	dev-qt/qtsvg:5
-	dev-qt/qtwebchannel:5
-	dev-qt/qtwebengine:5
-	dev-qt/qtwidgets:5
-	dev-qt/qtxml:5"
-DEPEND="${RDEPEND}
-	dev-libs/boost
-	dev-qt/qttest:5
-	net-misc/curl
-	sys-libs/zlib"
-BDEPEND="dev-qt/linguist-tools:5"
-
-DOCS=( ChangeLog README.md )
-
-src_prepare() {
-	cmake_src_prepare
-
-	sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
-		-i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
-}
-
-src_configure() {
-	local mycmakeargs=(
-		-DBUILD_HANDBOOK_HTML=no
-		-DBUILD_HANDBOOK_PDF=no
-		-DBUILD_HOWTO_HTML=no
-		-DBUILD_HOWTO_PDF=no
-	)
-	cmake_src_configure
-}
-
-pkg_postinst() {
-	xdg_icon_cache_update
-}
-
-pkg_postrm() {
-	xdg_icon_cache_update
-}
diff --git a/app-text/bibletime/bibletime-3.0.3-r2.ebuild b/app-text/bibletime/bibletime-3.0.3-r2.ebuild
new file mode 100644
index 000000000000..810bcbf14e96
--- /dev/null
+++ b/app-text/bibletime/bibletime-3.0.3-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Bible-study application using the SWORD library"
+HOMEPAGE="https://bibletime.info/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-text/sword-1.8.1
+	dev-cpp/clucene
+	dev-qt/qtcore:5
+	dev-qt/qtgui:5
+	dev-qt/qtprintsupport:5
+	dev-qt/qtsvg:5
+	dev-qt/qtwebchannel:5
+	dev-qt/qtwebengine:5
+	dev-qt/qtwidgets:5
+	dev-qt/qtxml:5"
+DEPEND="${RDEPEND}
+	dev-libs/boost
+	dev-libs/icu
+	dev-qt/qttest:5
+	net-misc/curl
+	sys-libs/zlib"
+BDEPEND="dev-qt/linguist-tools:5"
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+	cmake_src_prepare
+
+	sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
+		-i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+}
+
+src_configure() {
+	local mycmakeargs=(
+		-DBUILD_HANDBOOK_HTML=no
+		-DBUILD_HANDBOOK_PDF=no
+		-DBUILD_HOWTO_HTML=no
+		-DBUILD_HOWTO_PDF=no
+	)
+	cmake_src_configure
+}
+
+pkg_postinst() {
+	xdg_icon_cache_update
+}
+
+pkg_postrm() {
+	xdg_icon_cache_update
+}
-- 
cgit v1.2.3-65-gdbad