From 6efeee059cb06ab44a6b46b2912c301a0a6f0656 Mon Sep 17 00:00:00 2001
From: Leonardo Hernández Hernández <leohdz172@proton.me>
Date: Sun, 3 Sep 2023 21:42:58 -0600
Subject: app-accessibility/sphinx2: update EAPI 6 -> 8
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me>
Signed-off-by: Sam James <sam@gentoo.org>
---
 app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild | 36 +++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild

(limited to 'app-accessibility/sphinx2')

diff --git a/app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild b/app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild
new file mode 100644
index 000000000000..fa5b70bb70c6
--- /dev/null
+++ b/app-accessibility/sphinx2/sphinx2-0.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=${P/_/}
+
+DESCRIPTION="CMU Speech Recognition-engine"
+HOMEPAGE="https://cmusphinx.github.io"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( AUTHORS ChangeLog README NEWS
+	   doc/{README.{bin,lib},SCHMM_format,filler.dict,phoneset{,-old}} )
+HTML_DOCS=( doc/{phoneset_s2,sphinx2}.html )
+
+PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
+
+src_prepare() {
+	default
+	mv configure.{in,ac} || die
+	eautoreconf
+}
+
+src_install() {
+	default
+
+	rm -r "${ED}/usr/share/${PN}/doc" || die
+	find "${ED}" -name '*.la' -delete || die
+}
-- 
cgit v1.2.3-65-gdbad