summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/kvazaar/files/ppc.patch19
-rw-r--r--media-libs/kvazaar/kvazaar-0.8.3.ebuild5
2 files changed, 22 insertions, 2 deletions
diff --git a/media-libs/kvazaar/files/ppc.patch b/media-libs/kvazaar/files/ppc.patch
new file mode 100644
index 000000000000..9ee9f70e49f1
--- /dev/null
+++ b/media-libs/kvazaar/files/ppc.patch
@@ -0,0 +1,19 @@
+commit 99e37ec23532a247b9e306ef87e9879385c625d8
+Author: Ari Lemmetti <ari.lemmetti@gmail.com>
+Date: Sat Jan 30 19:33:09 2016 +0200
+
+ Update old pixel type to the current one
+
+diff --git a/src/strategies/altivec/picture-altivec.c b/src/strategies/altivec/picture-altivec.c
+index 7c9d1fb..28e86e8 100644
+--- a/src/strategies/altivec/picture-altivec.c
++++ b/src/strategies/altivec/picture-altivec.c
+@@ -28,7 +28,7 @@
+ #include <stdlib.h>
+
+
+-static unsigned reg_sad_altivec(const pixel * const data1, const pixel * const data2,
++static unsigned reg_sad_altivec(const kvz_pixel * const data1, const kvz_pixel * const data2,
+ const int width, const int height, const unsigned stride1, const unsigned stride2)
+ {
+ vector unsigned int vsad = {0,0,0,0}, vzero = {0,0,0,0};
diff --git a/media-libs/kvazaar/kvazaar-0.8.3.ebuild b/media-libs/kvazaar/kvazaar-0.8.3.ebuild
index 972f429e423d..f61e9fe1c750 100644
--- a/media-libs/kvazaar/kvazaar-0.8.3.ebuild
+++ b/media-libs/kvazaar/kvazaar-0.8.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
fi
-inherit multilib autotools multilib-minimal toolchain-funcs ${SCM}
+inherit eutils multilib autotools multilib-minimal toolchain-funcs ${SCM}
DESCRIPTION="An open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
@@ -35,6 +35,7 @@ DEPEND="${DEPEND}
abi_x86_64? ( ${ASM_DEP} )"
src_prepare() {
+ epatch "${FILESDIR}/ppc.patch"
eautoreconf
}