summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dolphin')
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild3
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild3
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild
index 33218b7db9b5..6ff4a8dd29b9 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506-r3.ebuild
@@ -129,6 +129,9 @@ src_prepare() {
# Remove dirty suffix: needed for netplay
sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
+
+ # Force Qt5 rather than automagic until support is properly handled here
+ sed -i -e '/NAMES Qt6 COMP/d' Source/Core/DolphinQt/CMakeLists.txt || die
}
src_configure() {
diff --git a/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild b/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild
index abcdeec7c45b..5d4b0219d150 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20220520-r1.ebuild
@@ -147,6 +147,9 @@ src_prepare() {
# Remove dirty suffix: needed for netplay
sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
+
+ # Force Qt5 rather than automagic until support is properly handled here
+ sed -i -e '/NAMES Qt6 COMP/d' Source/Core/DolphinQt/CMakeLists.txt || die
}
src_configure() {
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index d888afe15b4d..ebe6fb575460 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -145,6 +145,9 @@ src_prepare() {
# Remove dirty suffix: needed for netplay
sed -i -e 's/--dirty/&=""/' CMakeLists.txt || die
+
+ # Force Qt5 rather than automagic until support is properly handled here
+ sed -i -e '/NAMES Qt6 COMP/d' Source/Core/DolphinQt/CMakeLists.txt || die
}
src_configure() {