summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pretend')
-rw-r--r--dev-python/pretend/Manifest2
-rw-r--r--dev-python/pretend/metadata.xml9
-rw-r--r--dev-python/pretend/pretend-1.0.7.ebuild19
-rw-r--r--dev-python/pretend/pretend-1.0.8.ebuild19
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pretend/Manifest b/dev-python/pretend/Manifest
new file mode 100644
index 000000000000..8f1ceecc9919
--- /dev/null
+++ b/dev-python/pretend/Manifest
@@ -0,0 +1,2 @@
+DIST pretend-1.0.7.tar.gz 4788 SHA256 306906ea041a41ba23171aaf82112b49c516edbb08a29c8d0f113ee5def86d19 SHA512 9caa134a6b495c34bd05449b50f8f30e40ddceca9f70448f1735ae6d229996eeee370d01d7a3ed9acc40f385247544c201676699483599d8790e1971b6899f40 WHIRLPOOL c20c888b65f63ef1c4ea616714703529e5bf743970350c29d187f8a69f15c3db4fb1beda57584bb327105824e4ea01badac69a6b8fa4792c4d2ff53378cc31e7
+DIST pretend-1.0.8.tar.gz 4848 SHA256 930f2c1e18503e8f8c403abe2e02166c4a881941745147e712cdd4f49f3fb964 SHA512 25011216947289d340fb979ebc9e2c7f000571f006cf5ce15f10ff0e013164e4329a3a66933d202acf8ced498929cf9e5a2a3666aafa00f78348400615c5cec8 WHIRLPOOL 3148c08f98deadfea44ff59e673d053fc770a01541fb3bdac6416d156ad720658c42cd72b0f96d138962f636aab8080624400589ac5245d458c2cdff04d22015
diff --git a/dev-python/pretend/metadata.xml b/dev-python/pretend/metadata.xml
new file mode 100644
index 000000000000..d9c43ee47ef8
--- /dev/null
+++ b/dev-python/pretend/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pretend</remote-id>
+ <remote-id type="github">alex/pretend</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pretend/pretend-1.0.7.ebuild b/dev-python/pretend/pretend-1.0.7.ebuild
new file mode 100644
index 000000000000..9d78f5e18536
--- /dev/null
+++ b/dev-python/pretend/pretend-1.0.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for stubbing in Python"
+HOMEPAGE="https://github.com/alex/pretend/ https://pypi.python.org/pypi/pretend/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/pretend/pretend-1.0.8.ebuild b/dev-python/pretend/pretend-1.0.8.ebuild
new file mode 100644
index 000000000000..7df731fe547d
--- /dev/null
+++ b/dev-python/pretend/pretend-1.0.8.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for stubbing in Python"
+HOMEPAGE="https://github.com/alex/pretend/ https://pypi.python.org/pypi/pretend/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"