summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DBI/DBI-1.643.0.ebuild')
-rw-r--r--dev-perl/DBI/DBI-1.643.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/DBI/DBI-1.643.0.ebuild b/dev-perl/DBI/DBI-1.643.0.ebuild
new file mode 100644
index 000000000000..51958a4867e0
--- /dev/null
+++ b/dev-perl/DBI/DBI-1.643.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=1.643
+DIST_EXAMPLES=("ex/*")
+inherit perl-module
+
+DESCRIPTION="Database independent interface for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/PlRPC-0.200.0
+ >=virtual/perl-Sys-Syslog-0.170.0
+ virtual/perl-File-Spec
+ !<=dev-perl/SQL-Statement-1.330.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-Test-Simple-0.900.0
+ )
+"
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+
+src_test() {
+ if [[ $(makeopts_jobs) -gt 70 ]]; then
+ einfo "Reducing jobs to 70. Bug: https://bugs.gentoo.org/675164"
+ MAKEOPTS="${MAKEOPTS} -j70";
+ fi
+ perl-module_src_test
+}