summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mathjax')
-rw-r--r--dev-libs/mathjax/mathjax-2.2.ebuild6
-rw-r--r--dev-libs/mathjax/mathjax-2.4.0.ebuild6
-rw-r--r--dev-libs/mathjax/mathjax-2.5.3.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/dev-libs/mathjax/mathjax-2.2.ebuild b/dev-libs/mathjax/mathjax-2.2.ebuild
index 5334ef6374fa..5ced6b508e51 100644
--- a/dev-libs/mathjax/mathjax-2.2.ebuild
+++ b/dev-libs/mathjax/mathjax-2.2.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+inherit eutils
+
DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
HOMEPAGE="http://www.mathjax.org/"
SRC_URI="https://github.com/mathjax/MathJax/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -33,7 +35,7 @@ make_webconf() {
}
src_prepare() {
- find . -name .gitignore -delete || die
+ egit_clean
}
src_install() {
diff --git a/dev-libs/mathjax/mathjax-2.4.0.ebuild b/dev-libs/mathjax/mathjax-2.4.0.ebuild
index 663ef8b95735..e12285e25843 100644
--- a/dev-libs/mathjax/mathjax-2.4.0.ebuild
+++ b/dev-libs/mathjax/mathjax-2.4.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+inherit eutils
+
DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
HOMEPAGE="http://www.mathjax.org/"
SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -33,7 +35,7 @@ make_webconf() {
}
src_prepare() {
- find . -name .gitignore -delete || die
+ egit_clean
}
src_install() {
diff --git a/dev-libs/mathjax/mathjax-2.5.3.ebuild b/dev-libs/mathjax/mathjax-2.5.3.ebuild
index a0042a5a30fb..c36f178b5462 100644
--- a/dev-libs/mathjax/mathjax-2.5.3.ebuild
+++ b/dev-libs/mathjax/mathjax-2.5.3.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+inherit eutils
+
DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
HOMEPAGE="http://www.mathjax.org/"
SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -33,7 +35,7 @@ make_webconf() {
}
src_prepare() {
- find . -name .gitignore -delete || die
+ egit_clean
}
src_install() {