summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfminer')
-rw-r--r--app-text/pdfminer/Manifest1
-rw-r--r--app-text/pdfminer/pdfminer-20191020.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/pdfminer/Manifest b/app-text/pdfminer/Manifest
index b44ac28ba6e2..34b19b986101 100644
--- a/app-text/pdfminer/Manifest
+++ b/app-text/pdfminer/Manifest
@@ -1 +1,2 @@
DIST pdfminer-20140328.tar.gz 4081233 BLAKE2B 60e8c8409269c158feda0f02b1dbf46d4bcd58e2f0a2ef0102e3c3c691d599eda9164b8e5dde4278522d9cfcca4e6962b31919b08f66053fb986ad3ded7da498 SHA512 8abb2328f7824ee980df0ce42d758c15534e97379ea9213b4aa1d29864d24d73c9e2d6020964e9ab734c0c6f7d1ae70bccbd6605168eaadf83923718a1f4849a
+DIST pdfminer-20191020.tar.gz 4168016 BLAKE2B 53658853f1c6948a3249b56769c4d9e28cfe8e977b8702c3802f2c3d64f5c9f1d228024a3cbc9a5f288f60c991b2738a7aa131021bdb47c1492c83f9682abb15 SHA512 6ba663440f0ac370742f3a300a55d5f810202d960253931dfdb109a30ce3f71cf3e3dd30af9d0f6257365972452813b4ebc2dbee8031e988b7efb9dac15075d4
diff --git a/app-text/pdfminer/pdfminer-20191020.ebuild b/app-text/pdfminer/pdfminer-20191020.ebuild
new file mode 100644
index 000000000000..77050f5937cf
--- /dev/null
+++ b/app-text/pdfminer/pdfminer-20191020.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool for extracting information from PDF documents"
+HOMEPAGE="https://euske.github.io/pdfminer/ https://pypi.org/project/pdfminer/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use examples && emake -C samples all
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && dodoc -r samples
+ distutils-r1_python_install_all
+}