summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libgepub')
-rw-r--r--app-text/libgepub/Manifest1
-rw-r--r--app-text/libgepub/libgepub-0.5.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-text/libgepub/Manifest b/app-text/libgepub/Manifest
index af1943e2e2b8..2c5899cdb569 100644
--- a/app-text/libgepub/Manifest
+++ b/app-text/libgepub/Manifest
@@ -1 +1,2 @@
DIST libgepub-0.4.tar.xz 246016 SHA256 5666a1c4d186d205bd2d91b71d4c1cd5426025569114a765dd913a564f149ff4 SHA512 dd3e9837ba2c5896319918bda19eec8ea790d54f7893ddca46774f96f8e09ac1962ae6cbfc0bcd23c15059c63683ef4a6673e05f8416b024591677fddfa3ca15 WHIRLPOOL 024fe741655adc6fafb66f797fe77e39845764d7fb328f8c553d3cd5917d00e996b030f83342af5789e00bd54569eb25cc0728fd690bf03ae62ab6a9aef96652
+DIST libgepub-0.5.2.tar.xz 27076 SHA256 848328999285441739a18664f62e8008aef8d87d1da00aeb91138035fc672b38 SHA512 9e8ba3acc717fe5d1957935b154776720fcdb90ab566e0888203bce4ea2281b84f9fe44d554f6b5cadb1bba3aeae8b5b9a759001f404c43fa46b0ba16b959e69 WHIRLPOOL fb4a89592f05c59e6782fe044df3ee5fb786e10fac0d3baf5da250cbac8273d590920bab6e401f7175949d890373326e7e37045a8768927c79e012518945f073
diff --git a/app-text/libgepub/libgepub-0.5.2.ebuild b/app-text/libgepub/libgepub-0.5.2.ebuild
new file mode 100644
index 000000000000..37ff044fb87c
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://git.gnome.org/browse/libgepub"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure \
+ -Denable-introspection=$(usex introspection true false)
+}