summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/quoter')
-rw-r--r--app-shells/quoter/quoter-3.0_p2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/quoter/quoter-3.0_p2-r1.ebuild b/app-shells/quoter/quoter-3.0_p2-r1.ebuild
new file mode 100644
index 000000000000..29b79f549ee0
--- /dev/null
+++ b/app-shells/quoter/quoter-3.0_p2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ rm -f "${ED}"/usr/bin/quoter_pipe.sh || die
+ insinto /usr/share/${PN}
+ doins bin/quoter_pipe.sh
+}