summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/zeal')
-rw-r--r--app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch21
-rw-r--r--app-doc/zeal/zeal-0.6.1.ebuild16
2 files changed, 30 insertions, 7 deletions
diff --git a/app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch b/app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch
new file mode 100644
index 000000000000..45459b8c3678
--- /dev/null
+++ b/app-doc/zeal/files/zeal-0.6.1-qt-5.15.patch
@@ -0,0 +1,21 @@
+From 064aaa05d6a3ba4ba3cf648199a3109aba2f41fe Mon Sep 17 00:00:00 2001
+From: Dmitry Atamanov <data-man@users.noreply.github.com>
+Date: Sun, 26 Apr 2020 02:26:53 +0500
+Subject: [PATCH] fix(ui): fix compilation error with Qt 5.15 (#1218)
+
+---
+ src/libs/ui/searchitemdelegate.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/libs/ui/searchitemdelegate.cpp b/src/libs/ui/searchitemdelegate.cpp
+index 464e4859..4a9c473b 100644
+--- a/src/libs/ui/searchitemdelegate.cpp
++++ b/src/libs/ui/searchitemdelegate.cpp
+@@ -27,6 +27,7 @@
+ #include <QFontMetrics>
+ #include <QHelpEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QToolTip>
+
+ using namespace Zeal::WidgetUi;
diff --git a/app-doc/zeal/zeal-0.6.1.ebuild b/app-doc/zeal/zeal-0.6.1.ebuild
index 19114642c849..6fe0106f71ea 100644
--- a/app-doc/zeal/zeal-0.6.1.ebuild
+++ b/app-doc/zeal/zeal-0.6.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Offline documentation browser inspired by Dash"
HOMEPAGE="https://zealdocs.org/"
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="vanilla"
DEPEND="
@@ -33,13 +32,16 @@ RDEPEND="
x11-themes/hicolor-icon-theme
"
+PATCHES=(
+ "${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
+ "${FILESDIR}/${P}-qt-5.15.patch"
+)
+
src_prepare() {
- default
- eapply "${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
if ! use vanilla; then
- eapply "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch"
+ PATCHES+=( "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch" )
fi
- cmake-utils_src_prepare
+ cmake_src_prepare
}
pkg_postinst() {