summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/sign')
-rw-r--r--app-crypt/sign/Manifest1
-rw-r--r--app-crypt/sign/files/1.0.7-as-needed.patch10
-rw-r--r--app-crypt/sign/files/1.0.7-openssl-0.9.8.patch12
-rw-r--r--app-crypt/sign/metadata.xml20
-rw-r--r--app-crypt/sign/sign-1.0.7.ebuild37
5 files changed, 80 insertions, 0 deletions
diff --git a/app-crypt/sign/Manifest b/app-crypt/sign/Manifest
new file mode 100644
index 000000000000..d01fd2ae5598
--- /dev/null
+++ b/app-crypt/sign/Manifest
@@ -0,0 +1 @@
+DIST sign-1.0.7.tar.gz 28535 SHA256 c5f005eff29880807af37a128724f064cccb166fc9f49acab5f1403c9b72d4b9 SHA512 9adb9e520da654e7196451e20501be8e1b84ee750a26344cb7e1816e56e4e8b88773a76a2707a6428faa7828658807eaaef2073b6940e212435ed915881885c0 WHIRLPOOL fdbd9530110ebe589f02818e62f455a56ff8a5473bf3dcf0ab78ec7341ab42e0e74701f65105cf3a38db094d637460de46971ff7096f9f5aa3084d922a7392bc
diff --git a/app-crypt/sign/files/1.0.7-as-needed.patch b/app-crypt/sign/files/1.0.7-as-needed.patch
new file mode 100644
index 000000000000..56574d7131d7
--- /dev/null
+++ b/app-crypt/sign/files/1.0.7-as-needed.patch
@@ -0,0 +1,10 @@
+diff -Nur sign-1.0.7.orig/src/Makefile sign-1.0.7/src/Makefile
+--- sign-1.0.7.orig/src/Makefile 2004-08-07 07:15:00.000000000 +0000
++++ sign-1.0.7/src/Makefile 2006-09-16 17:21:12.400977608 +0000
+@@ -1,5 +1,5 @@
+ CFLAGS += -Wall -DNDEBUG -g
+-LDFLAGS += -lcrypto
++LDLIBS += -lcrypto
+
+ OBJS = buf.o die.o msg.o digest.o uue.o pki.o str.o system-nix.o \
+ system-nix-readpass.o util.o
diff --git a/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch b/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
new file mode 100644
index 000000000000..179efbe77ef5
--- /dev/null
+++ b/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
@@ -0,0 +1,12 @@
+diff -Nur sign-1.0.7.orig/src/pki.c sign-1.0.7/src/pki.c
+--- sign-1.0.7.orig/src/pki.c 2004-08-04 04:10:35.000000000 +0000
++++ sign-1.0.7/src/pki.c 2006-09-16 17:17:34.335535125 +0000
+@@ -286,7 +286,7 @@
+
+ /* if it's not a decryption problem - bail out */
+ if (ERR_get_error() != ERR_PACK(ERR_LIB_EVP,
+- EVP_F_EVP_DECRYPTFINAL,
++ EVP_F_EVP_DECRYPTFINAL_EX,
+ EVP_R_BAD_DECRYPT))
+ goto cleanup;
+
diff --git a/app-crypt/sign/metadata.xml b/app-crypt/sign/metadata.xml
new file mode 100644
index 000000000000..22b9e39501a4
--- /dev/null
+++ b/app-crypt/sign/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>alicef@gentoo.org</email>
+ <name>Alice Ferrazzi</name>
+ <description>Assign bugs to me.</description>
+</maintainer>
+<maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ <description>CC him on bugs.</description>
+</maintainer>
+<longdescription>
+sign is a file signing and signature verification utility. It's main purpose is
+to be a simple and convenient extension to a tar/gz/bzip2 line of tools to check
+file integrity and authenticity. It's small and simple, it does just one thing
+and hopefully does it well.
+</longdescription>
+</pkgmetadata>
diff --git a/app-crypt/sign/sign-1.0.7.ebuild b/app-crypt/sign/sign-1.0.7.ebuild
new file mode 100644
index 000000000000..3277e9e9ba25
--- /dev/null
+++ b/app-crypt/sign/sign-1.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="File signing and signature verification utility"
+HOMEPAGE="http://swapped.cc/sign/"
+SRC_URI="http://swapped.cc/${PN}/files/${P}.tar.gz"
+
+LICENSE="BZIP2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=">=dev-libs/openssl-0.9.8"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-openssl-0.9.8.patch
+ epatch "${FILESDIR}"/${PV}-as-needed.patch
+ # remove -g from CFLAGS, it happens to break the build on ppc-macos
+ sed -i -e 's/-g//' src/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman man/${PN}.1
+ dodoc README
+ dosym ${PN} /usr/bin/un${PN}
+}