summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rotp/rotp-6.2.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ruby/rotp/rotp-6.2.0.ebuild b/dev-ruby/rotp/rotp-6.2.0.ebuild
index 8b16fcb7f638..1d586425b666 100644
--- a/dev-ruby/rotp/rotp-6.2.0.ebuild
+++ b/dev-ruby/rotp/rotp-6.2.0.ebuild
@@ -28,4 +28,9 @@ ruby_add_bdepend "
all_ruby_prepare() {
# Remove simplecov
sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+ # Don't require git
+ sed -i \
+ -e 's/git ls-files/find/' \
+ -e 's/{test,spec,features}/spec/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
}