summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/glamor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/glamor')
-rw-r--r--x11-libs/glamor/Manifest1
-rw-r--r--x11-libs/glamor/files/glamor-0.6.0-glamor_egl_create_argb8888.patch31
-rw-r--r--x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch30
-rw-r--r--x11-libs/glamor/glamor-0.6.0-r1.ebuild54
-rw-r--r--x11-libs/glamor/glamor-0.6.0.ebuild53
-rw-r--r--x11-libs/glamor/metadata.xml8
6 files changed, 177 insertions, 0 deletions
diff --git a/x11-libs/glamor/Manifest b/x11-libs/glamor/Manifest
new file mode 100644
index 000000000000..df5f4e06c41c
--- /dev/null
+++ b/x11-libs/glamor/Manifest
@@ -0,0 +1 @@
+DIST glamor-egl-0.6.0.tar.bz2 428912 SHA256 66531b56e6054eb53daa7bd57eb6358a7ead1b84f63419606e69d1092365e5c9 SHA512 aa3a88e85ae069e487c88a1839c21b0404c5a2a343a63f2c1d71ffb8d86288eb42dfcb30c8cce4c417b361417e9fae7c1cdabadc07ad40bb97c995c410dc0c1b WHIRLPOOL 54965c21eb65a73ecc7227de511b2d2e37760fefe90a9145385f4202d03286004af4a89edc5e251538e500e5d17efca0b82419d23112a4df441504747b1d8f24
diff --git a/x11-libs/glamor/files/glamor-0.6.0-glamor_egl_create_argb8888.patch b/x11-libs/glamor/files/glamor-0.6.0-glamor_egl_create_argb8888.patch
new file mode 100644
index 000000000000..b9de24177bb8
--- /dev/null
+++ b/x11-libs/glamor/files/glamor-0.6.0-glamor_egl_create_argb8888.patch
@@ -0,0 +1,31 @@
+From cccfea4454949e3e376be42bb230603848997195 Mon Sep 17 00:00:00 2001
+From: Axel Davy <axel.davy@ens.fr>
+Date: Tue, 04 Mar 2014 09:38:55 +0000
+Subject: Fix a missing MakeCurrent in glamor_egl_create_argb8888_based_texture
+
+There is a missing MakeCurrent before creating the texture
+and link it to the EGLImage.
+
+This fixes an X server crash with the piglit test
+glx-make-current-multi-process on radeonsi from current Mesa Git.
+
+Signed-off-by: Axel Davy <axel.davy@ens.fr>
+Tested-by: Michel Dänzer <michel.daenzer@amd.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+diff --git a/src/glamor_egl.c b/src/glamor_egl.c
+index ff4c0bd..ffa95a7 100644
+--- a/src/glamor_egl.c
++++ b/src/glamor_egl.c
+@@ -252,7 +252,9 @@ glamor_egl_create_argb8888_based_texture(ScreenPtr screen,
+ gbm_bo_destroy(bo);
+ if (image == EGL_NO_IMAGE_KHR)
+ return 0;
++ glamor_egl_make_current(screen);
+ glamor_create_texture_from_image(glamor_egl, image, &texture);
++ glamor_egl_restore_context(screen);
+ glamor_egl->egl_destroy_image_khr(glamor_egl->display, image);
+
+ return texture;
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch b/x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch
new file mode 100644
index 000000000000..ebd5433bdbe9
--- /dev/null
+++ b/x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch
@@ -0,0 +1,30 @@
+From 55257ac3ee92143d0d8339faa0272f95a792febb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ch=C3=AD-Thanh=20Christopher=20Nguy=E1=BB=85n?=
+ <chithanh@gentoo.org>
+Date: Tue, 11 Feb 2014 12:08:07 +0100
+Subject: [PATCH] glamor_xv: add missing include
+
+glamor_xv.c uses DamageDamageRegion but does not include xorg/damage.h. This
+causes the build to fail if 9b8217f9ef6279fff6628631d18497bed0343ef9 is not
+present in the X server.
+
+Bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=499442
+---
+ src/glamor_xv.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/glamor_xv.c b/src/glamor_xv.c
+index a89b4cd..b40b6e8 100644
+--- a/src/glamor_xv.c
++++ b/src/glamor_xv.c
+@@ -37,6 +37,7 @@
+ #ifdef GLAMOR_XV
+ #include "xf86xv.h"
+ #include <X11/extensions/Xv.h>
++#include <xorg/damage.h>
+ #include "fourcc.h"
+ /* Reference color space transform data */
+ typedef struct tagREF_TRANSFORM
+--
+1.8.3.2
+
diff --git a/x11-libs/glamor/glamor-0.6.0-r1.ebuild b/x11-libs/glamor/glamor-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..453e142ff70c
--- /dev/null
+++ b/x11-libs/glamor/glamor-0.6.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DRI=always
+XORG_EAUTORECONF=yes
+XORG_MODULE=driver/
+XORG_MODULE_REBUILD=yes
+S=${WORKDIR}/${PN}-egl-${PV}
+
+inherit xorg-2 autotools-utils toolchain-funcs
+
+DESCRIPTION="OpenGL based 2D rendering acceleration library"
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/${XORG_MODULE}${PN}-egl-${PV}.tar.bz2"
+
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="gles xv"
+
+RDEPEND=">=x11-base/xorg-server-1.10
+ >=media-libs/mesa-10[egl,gbm]
+ gles? (
+ || ( media-libs/mesa[gles2] media-libs/mesa[gles] )
+ )
+ >=x11-libs/pixman-0.21.8"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-xv-add-missing-include.patch
+ "${FILESDIR}"/${P}-glamor_egl_create_argb8888.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable gles glamor-gles2)
+ $(use_enable xv)
+ )
+ xorg-2_src_configure
+}
+
+src_prepare() {
+ sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
+ xorg-2_src_prepare
+ # fail to load grafic driver with hardened compiler #488906
+ if gcc-specs-now ; then
+ append-ldflags -Wl,-z,lazy
+ fi
+}
+
+src_install() {
+ # workaround parallel install failure, bug #488124.
+ autotools-utils_src_install -j1
+}
diff --git a/x11-libs/glamor/glamor-0.6.0.ebuild b/x11-libs/glamor/glamor-0.6.0.ebuild
new file mode 100644
index 000000000000..f7447da96e00
--- /dev/null
+++ b/x11-libs/glamor/glamor-0.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DRI=always
+XORG_EAUTORECONF=yes
+XORG_MODULE=driver/
+XORG_MODULE_REBUILD=yes
+S=${WORKDIR}/${PN}-egl-${PV}
+
+inherit xorg-2 autotools-utils toolchain-funcs
+
+DESCRIPTION="OpenGL based 2D rendering acceleration library"
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/${XORG_MODULE}${PN}-egl-${PV}.tar.bz2"
+
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="gles xv"
+
+RDEPEND=">=x11-base/xorg-server-1.10
+ >=media-libs/mesa-10[egl,gbm]
+ gles? (
+ || ( media-libs/mesa[gles2] media-libs/mesa[gles] )
+ )
+ >=x11-libs/pixman-0.21.8"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-xv-add-missing-include.patch
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable gles glamor-gles2)
+ $(use_enable xv)
+ )
+ xorg-2_src_configure
+}
+
+src_prepare() {
+ sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
+ xorg-2_src_prepare
+ # fail to load grafic driver with hardened compiler #488906
+ if gcc-specs-now ; then
+ append-ldflags -Wl,-z,lazy
+ fi
+}
+
+src_install() {
+ # workaround parallel install failure, bug #488124.
+ autotools-utils_src_install -j1
+}
diff --git a/x11-libs/glamor/metadata.xml b/x11-libs/glamor/metadata.xml
new file mode 100644
index 000000000000..a83e1d54614a
--- /dev/null
+++ b/x11-libs/glamor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name='gles'>Build glamor based on gles2</flag>
+</use>
+</pkgmetadata>