summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-08-07 07:44:05 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-20 09:37:35 +0300
commit6f6467448a05247ce78d9e7a512bd238798dcbca (patch)
treed89ea2e8253b8e2f18967170737cfc18093ec817 /www-apps
parentwww-client/seamonkey: migrate to llvm-r1.eclass (diff)
downloadgentoo-6f6467448a05247ce78d9e7a512bd238798dcbca.tar.gz
gentoo-6f6467448a05247ce78d9e7a512bd238798dcbca.tar.bz2
gentoo-6f6467448a05247ce78d9e7a512bd238798dcbca.zip
www-apps/hugo: add 0.131.0
Signed-off-by: tastytea <gentoo@tastytea.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.131.0.ebuild125
2 files changed, 127 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index c3399670bb76..b7b83489f5dd 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -6,3 +6,5 @@ DIST hugo-0.128.2-vendor.tar.xz 6698936 BLAKE2B 28762e61a7e7452545889f31a751dea2
DIST hugo-0.128.2.tar.gz 20239793 BLAKE2B 47d75606053e44a0f863dbb88050ff5323e33c1306a47baff237db7fa41dce0559960785105ad8643dcef1eeb149054b5536da168ff978ac0b5c3c5398379b6f SHA512 4710fceb11872577a1d9c929d296dc79829135af0c509ac0b7b8142568b0e907c2de28c9f482cc1138d9595086363397166eb2ca208fa4fdf1beadd168558787
DIST hugo-0.129.0-vendor.tar.xz 6766128 BLAKE2B 31f723bdefd45a8e595c09b2d579ff68e2d3dc2e48c276a7963348c0d791c443b1a7e09c15a6aec955dca4928e695516c3777c6550230f455bb7f9c7ac3b6483 SHA512 97044f53cab10484731fc42aabcb63484759f00e80e29237d9819af49c6ab5fefeddde37fc971f9c47c9f24e607c0691cfb8a564e6de7f5a017b0ef93e8c7d89
DIST hugo-0.129.0.tar.gz 20241492 BLAKE2B aaa6ced77b936a34e0ebe24f2a2c51cd992464cbfd93b33682f0b0c501e6809d5c13960c1bec82611ebd043631bb2e2bae13348475641e8b7736b4980a3b3a1f SHA512 0845f417af97ee068ad0c971684522fa49fcfca47de5db71f0026fd3c59baddcc03c73560275ff91e4c85286cf855a2b3b0271ee019141d71e04f6b31a91ae87
+DIST hugo-0.131.0-vendor.tar.xz 6925652 BLAKE2B 352cf39d95cf30ab502d91a816b151e2e94e1b57e59e6b3171caf83908dbc8726e03413fdf89a6fa7a360ee8b6ee0a3122f9f1fff2143985e1d33693ee3de114 SHA512 e1265f15e19f531360d447f9fc77da5dc894a3fd1d289df41bfbcfcc740b10e43ce1c872c69d0dfcf32cdff5c5a5edf34df64f107e6c20869eec3bf1668bdea1
+DIST hugo-0.131.0.tar.gz 20323531 BLAKE2B b88be13c6d1008a777114e5c0f42dac0277f37ba36ea601903f9a6e63b06fad3d847950aada082ad32dea544df54f1ad90c2ecbddebbcd70e73a74c416aebaf9 SHA512 53bb387bde6c6e92568036d06db1dfeaa9f897806f7f51cb4b9c3fd93026a41410ea61598370da79abb5df20e81b18616e3ec49e7cec1bb1e470d5035b594ef6
diff --git a/www-apps/hugo/hugo-0.131.0.ebuild b/www-apps/hugo/hugo-0.131.0.ebuild
new file mode 100644
index 000000000000..e9550f242204
--- /dev/null
+++ b/www-apps/hugo/hugo-0.131.0.ebuild
@@ -0,0 +1,125 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit check-reqs go-module shell-completion
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +extended test"
+
+BDEPEND="
+ >=dev-lang/go-1.22.2
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ )
+"
+RDEPEND="
+ extended? (
+ dev-libs/libsass:=
+ >=media-libs/libwebp-1.3.2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.121.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.128.0-skip-some-tests.patch
+)
+
+_check_reqs() {
+ if [[ ${MERGE_TYPE} == binary ]] ; then
+ return 0
+ fi
+
+ if has test ${FEATURES}; then
+ CHECKREQS_DISK_BUILD="4G"
+ else
+ CHECKREQS_DISK_BUILD="1500M"
+ fi
+ check-reqs_${EBUILD_PHASE_FUNC}
+}
+
+pkg_pretend() {
+ _check_reqs
+}
+
+pkg_setup() {
+ _check_reqs
+}
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev extended "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor,__disable,_get,_get_u,_npm{,_withexisting}}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ if ! has_version -b virtual/pandoc ; then
+ elog "You're missing virtual/pandoc - some tests will be skipped."
+ fi
+
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+ dofishcomp completions/${PN}.fish
+ dozshcomp completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "the sass USE-flag was renamed to extended. the functionality is the" \
+ "same, except it also toggles the dependency on libwebp (for encoding)"
+}