summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>2023-06-21 21:31:18 +0200
committerSam James <sam@gentoo.org>2023-06-24 02:13:38 +0100
commit785ca73c91f26ac53fcff8d753f5569916877168 (patch)
treed2b4ef47f20529a13da4a4e236258deff8d0e871 /sys-block/zram-init
parentsys-auth/pam_require: drop unnecessary die, style tweaks (diff)
downloadgentoo-785ca73c91f26ac53fcff8d753f5569916877168.tar.gz
gentoo-785ca73c91f26ac53fcff8d753f5569916877168.tar.bz2
gentoo-785ca73c91f26ac53fcff8d753f5569916877168.zip
sys-block/zram-init: add 11.1
Signed-off-by: Mattéo Rossillol‑‑Laruelle <beatussum@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block/zram-init')
-rw-r--r--sys-block/zram-init/Manifest1
-rw-r--r--sys-block/zram-init/zram-init-11.1.ebuild74
-rw-r--r--sys-block/zram-init/zram-init-9999.ebuild23
3 files changed, 89 insertions, 9 deletions
diff --git a/sys-block/zram-init/Manifest b/sys-block/zram-init/Manifest
index cbce8d6f025f..0663bc8a1502 100644
--- a/sys-block/zram-init/Manifest
+++ b/sys-block/zram-init/Manifest
@@ -1,3 +1,4 @@
DIST zram-init-10.5.tar.gz 20496 BLAKE2B a28ba9e3813be7ca571ac033ca7b4bdf7c95624f9be72288d8478a2fffa950f7bb18fe865b9933fd209dabc705366af8f825fa7ee8a16be364e1d71c7062067c SHA512 97591549aa9b678b0b12efcc27136826c19b42cc0cf027a3f251843ef5678425568c9eb573d24661ce795eede1d136243fcccbf4dcd62e9d61eb7d775f84f1c1
DIST zram-init-11.0.tar.gz 21069 BLAKE2B f1a41cad3aad89bde2343a079e31d66de15d051c8431edc08999965993c6f894959289a01415259a93c8691dfec5316ebcb28d0a81844e985395ca5592654f12 SHA512 f11c7ad4e684701ab7c89cb1e859c6ee58ff6795f03b584884f64341d511a8c2de375fc43463318220fab2e16632807d8a13e9b6ac502fa933d406996bf4d115
+DIST zram-init-11.1.tar.gz 21117 BLAKE2B c6e99e9df97fe44b4081ce304dd2cd72fbdfa3c705f6cc02787df0376dd04a93cd8fbbf327c05f2f96ad8b6383f4c155e2859c0718c81a6bff50d0b91fb93322 SHA512 dcbfe9bb085e1bb1856f53fb5722fc008a8b7b8099423be174f02fcaa4093c19e24c33f08deeec9d1525b9512b7c5640c4ac396c60f7b6016b56edeb38a64285
DIST zram-init-8.1.tar.gz 9177 BLAKE2B 229a469aeeb0b22b80f48d946d4ff746c7bd5d7b58ea9290db0da011df6d618c7c55ad95810b0be74ff81350182057d9067e834ecba688eb4ffa668521468a8b SHA512 8f688accb7a4231f705f694c4b4e7344bbb338b2b1f09a6dacd900020a4e8583105b25fef5b40f39630db88db6fcc8ec79824945ceaee95ea1279d09d081a994
diff --git a/sys-block/zram-init/zram-init-11.1.ebuild b/sys-block/zram-init/zram-init-11.1.ebuild
new file mode 100644
index 000000000000..8bf1b864bb46
--- /dev/null
+++ b/sys-block/zram-init/zram-init-11.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit prefix readme.gentoo-r1
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zRAM"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
+else
+ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT="binchecks strip test"
+
+BDEPEND="sys-devel/gettext"
+
+RDEPEND="
+ >=app-shells/push-2.0
+ virtual/libintl
+ || ( sys-apps/openrc sys-apps/systemd )
+"
+
+DISABLE_AUTOFORMATTING=true
+DOC_CONTENTS="\
+To use zram-init, activate it in your kernel and add it to the default
+runlevel:
+ rc-update add zram-init default
+If you use systemd enable zram_swap, zram_tmp, and/or zram_var_tmp with
+systemctl. You might need to modify the following file depending on the number
+of devices that you want to create:
+ /etc/modprobe.d/zram.conf.
+If you use the \$TMPDIR as zram device with OpenRC, you should add zram-init to
+the boot runlevel:
+ rc-update add zram-init boot
+Still for the same case, you should add in the OpenRC configuration file for
+the services using \$TMPDIR the following line:
+ rc_need=\"zram-init\""
+
+src_prepare() {
+ default
+
+ hprefixify "${S}/man/${PN}.8"
+
+ hprefixify -e "s%(}|:)(/(usr/)?sbin)%\1${EPREFIX}\2%g" \
+ "${S}/sbin/${PN}.in"
+
+ hprefixify -e "s%( |=)(/tmp)%\1${EPREFIX}\2%g" \
+ "${S}/systemd/system"/* \
+ "${S}/openrc"/*/*
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr" MODIFY_SHEBANG=FALSE
+}
+
+src_install() {
+ einstalldocs
+ readme.gentoo_create_doc
+
+ emake DESTDIR="${ED}" PREFIX="/usr" BINDIR="${ED}/sbin" SYSCONFDIR="/etc" \
+ SYSTEMDDIR="${ED}/lib/systemd/system" install
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/sys-block/zram-init/zram-init-9999.ebuild b/sys-block/zram-init/zram-init-9999.ebuild
index e6b8db2062ea..8bf1b864bb46 100644
--- a/sys-block/zram-init/zram-init-9999.ebuild
+++ b/sys-block/zram-init/zram-init-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit prefix readme.gentoo-r1
@@ -12,12 +12,13 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
else
- SRC_URI="https://github.com/vaeth/zram-init/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
+RESTRICT="binchecks strip test"
BDEPEND="sys-devel/gettext"
@@ -30,14 +31,18 @@ RDEPEND="
DISABLE_AUTOFORMATTING=true
DOC_CONTENTS="\
To use zram-init, activate it in your kernel and add it to the default
-runlevel: rc-update add zram-init default
+runlevel:
+ rc-update add zram-init default
If you use systemd enable zram_swap, zram_tmp, and/or zram_var_tmp with
systemctl. You might need to modify the following file depending on the number
-of devices that you want to create: /etc/modprobe.d/zram.conf.
+of devices that you want to create:
+ /etc/modprobe.d/zram.conf.
If you use the \$TMPDIR as zram device with OpenRC, you should add zram-init to
-the boot runlevel: rc-update add zram-init boot
+the boot runlevel:
+ rc-update add zram-init boot
Still for the same case, you should add in the OpenRC configuration file for
-the services using \$TMPDIR the following line: rc_need=\"zram-init\""
+the services using \$TMPDIR the following line:
+ rc_need=\"zram-init\""
src_prepare() {
default
@@ -60,8 +65,8 @@ src_install() {
einstalldocs
readme.gentoo_create_doc
- emake DESTDIR="${ED}" PREFIX="/usr" SYSCONFDIR="/etc" \
- BINDIR="${ED}/sbin" SYSTEMDDIR="${ED}/lib/systemd/system" install
+ emake DESTDIR="${ED}" PREFIX="/usr" BINDIR="${ED}/sbin" SYSCONFDIR="/etc" \
+ SYSTEMDDIR="${ED}/lib/systemd/system" install
}
pkg_postinst() {