summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-11-02 12:51:52 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-11-02 13:05:46 +0100
commit35b6860ddb9bac481e69cad6c2077f1ade404045 (patch)
tree2b3aa5397533297604991b22019f90a63dcbfde4 /sys-auth
parentsys-auth/AusweisApp: drop 2.2.0 (diff)
downloadgentoo-35b6860ddb9bac481e69cad6c2077f1ade404045.tar.gz
gentoo-35b6860ddb9bac481e69cad6c2077f1ade404045.tar.bz2
gentoo-35b6860ddb9bac481e69cad6c2077f1ade404045.zip
sys-auth/AusweisApp: add 2.2.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp/AusweisApp-2.2.2.ebuild47
-rw-r--r--sys-auth/AusweisApp/Manifest1
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp/AusweisApp-2.2.2.ebuild b/sys-auth/AusweisApp/AusweisApp-2.2.2.ebuild
new file mode 100644
index 000000000000..d86746427953
--- /dev/null
+++ b/sys-auth/AusweisApp/AusweisApp-2.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-qt/qtshadertools:6
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtbase:6[concurrent,network,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ dev-qt/qtwebsockets:6[qml]
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp/Manifest b/sys-auth/AusweisApp/Manifest
index 599d927e7039..b4d164aae8e5 100644
--- a/sys-auth/AusweisApp/Manifest
+++ b/sys-auth/AusweisApp/Manifest
@@ -1 +1,2 @@
DIST AusweisApp-2.2.1.tar.gz 5929111 BLAKE2B b6ad3f09597a31d9be347d0b3dfeadb0d0b5ea48e5c257989b38180a09f7ef5f0e6fdec66942c9ff3d173dece7a84ae122c4180705c909becd552d96c92493c3 SHA512 6d1c5ab27fe2ab8fe17f238d27321562e9546cdbb09999472ae2490bc0c3990d43af20557a1a88fff54faad6bed56e97c90732159a1d52683cce0d42c43b2e83
+DIST AusweisApp-2.2.2.tar.gz 5943648 BLAKE2B 3857177c7f54ad807de480345d22e38c8160b57d51851af7c53f46307ccd5e5150d7800ed26f8f527b0ef2ec725ae2c9c1c62fba4f35007c16886184352a6440 SHA512 2e0e101d5623ea97a04710fa8dcfdd9be96df71d80f5f6aa4fbb515a6f7ca4d62df766c16b21ad48720b21eb541f22287213adb71bd1d93cee00f9839c303169