summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 01:04:39 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 03:30:46 +0200
commit1d99cdeaf2d8847804e4fc28bfd30635f4ae3322 (patch)
tree4023d6f2edae86258c301190b1be7b66d3d6d507 /sys-apps/ifd-gempc
parentsys-apps/pcsc-slb-rf72-drv: eapi cleanups (diff)
downloadgentoo-1d99cdeaf2d8847804e4fc28bfd30635f4ae3322.tar.gz
gentoo-1d99cdeaf2d8847804e4fc28bfd30635f4ae3322.tar.bz2
gentoo-1d99cdeaf2d8847804e4fc28bfd30635f4ae3322.zip
sys-apps/ifd-gempc: eapi bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'sys-apps/ifd-gempc')
-rw-r--r--sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild b/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
index 6575b4594b59..bca99c3cffd5 100644
--- a/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
+++ b/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit toolchain-funcs
@@ -14,19 +14,24 @@ SLOT="0"
SRC_URI="http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/${P}.tar.gz"
IUSE=""
RDEPEND=">=sys-apps/pcsc-lite-1.2.9_beta7
- =virtual/libusb-0*"
+ virtual/libusb:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+DOCS=(
+ README README.410 README.430
+)
+
src_compile() {
emake CC="$(tc-getCC)"
}
src_install () {
+ emake CC="$(tc-getCC)" DESTDIR="${D}" install
+ einstalldocs
+
local pcscdir="$(pkg-config --variable=usbdropdir libpcsclite)"
local conf="/etc/reader.conf.d/${PN}.conf"
- emake CC="$(tc-getCC)" DESTDIR="${D}" install
- dodoc README*
dodir "$(dirname "${conf}")"
insinto "$(dirname "${conf}")"
newins "${FILESDIR}/reader.conf" "$(basename "${conf}")"