summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-15 14:20:19 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-15 14:21:43 -0800
commit5b02ae2fc1b05e3ed4f336cf758de3d9c8e9576e (patch)
treed2feb65ab18ca88bf7c7d50859f9350069a37b99 /sys-apps/coreutils
parentsci-libs/opencascade: rename gles2 USE flag to gles2-only (diff)
downloadgentoo-5b02ae2fc1b05e3ed4f336cf758de3d9c8e9576e.tar.gz
gentoo-5b02ae2fc1b05e3ed4f336cf758de3d9c8e9576e.tar.bz2
gentoo-5b02ae2fc1b05e3ed4f336cf758de3d9c8e9576e.zip
sys-apps/coreutils: remove zfs check
it has served it's purpose and no longer needed coreutils-9 will go stable soon too Closes: https://bugs.gentoo.org/830830 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/coreutils-9.0-r1.ebuild42
-rw-r--r--sys-apps/coreutils/coreutils-9.0.ebuild42
2 files changed, 2 insertions, 82 deletions
diff --git a/sys-apps/coreutils/coreutils-9.0-r1.ebuild b/sys-apps/coreutils/coreutils-9.0-r1.ebuild
index f8036f5a79b2..6f7eccb90d52 100644
--- a/sys-apps/coreutils/coreutils-9.0-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-9.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -58,46 +58,6 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
-pkg_pretend() {
- if has_version "<sys-fs/zfs-9999" && grep -q zfs <(lsmod 2>/dev/null) ; then
- einfo "Checking for running ZFS module version"
-
- local kmodv minver
- kmodv="$(grep kmod <(zfs -V 2>/dev/null))"
- # Convert zfs-kmod-2.1.1-r3-gentoo -> 2.1.1-r3
- kmodv="${kmodv//zfs-kmod-}"
- kmodv="${kmodv%%-gentoo}"
-
- minver="$(ver_cut 2 ${kmodv})"
- local diemsg=$(cat <<-EOF
- Attempted installation of ${P} on unsupported version of zfs-kmod!
- Please reboot to a newer version of zfs-kmod first:
- zfs-kmod >=2.0.7 or zfs-kmod >=2.1.1-r3
- Using ${P} with running version of zfs-kmod of can
- lead to data loss while using cp command on some configurations.
- See https://github.com/openzfs/zfs/issues/11900 for details.
- EOF
- )
-
- case "${minver}" in
- # 2.0.x
- 0)
- ver_test "${kmodv}" -lt 2.0.7 && die "${diemsg}"
- ;;
- # 2.1.x
- 1)
- ver_test "${kmodv}" -lt 2.1.1-r3 && die "${diemsg}"
- ;;
- # 0.8.x/9999
- *)
- # We can't really cover this case realistically
- # 9999 is too hard to check and 0.8.x isn't being supported anymore.
- ;;
- esac
- fi
-
-}
-
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup
diff --git a/sys-apps/coreutils/coreutils-9.0.ebuild b/sys-apps/coreutils/coreutils-9.0.ebuild
index 231339807e73..ecfbcd3f4be6 100644
--- a/sys-apps/coreutils/coreutils-9.0.ebuild
+++ b/sys-apps/coreutils/coreutils-9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -58,46 +58,6 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
-pkg_pretend() {
- if has_version "<sys-fs/zfs-9999" ; then
- einfo "Checking for running ZFS module version"
-
- local kmodv minver
- kmodv="$(grep kmod <(zfs -V 2>/dev/null))"
- # Convert zfs-kmod-2.1.1-r3-gentoo -> 2.1.1-r3
- kmodv="${kmodv//zfs-kmod-}"
- kmodv="${kmodv%%-gentoo}"
-
- minver="$(ver_cut 2 ${kmodv})"
- local diemsg=$(cat <<-EOF
- Attempted installation of ${P} on unsupported version of zfs-kmod!
- Please reboot to a newer version of zfs-kmod first:
- zfs-kmod >=2.0.7 or zfs-kmod >=2.1.1-r3
- Using ${P} with running version of zfs-kmod of can
- lead to data loss while using cp command on some configurations.
- See https://github.com/openzfs/zfs/issues/11900 for details.
- EOF
- )
-
- case "${minver}" in
- # 2.0.x
- 0)
- ver_test "${kmodv}" -lt 2.0.7 && die "${diemsg}"
- ;;
- # 2.1.x
- 1)
- ver_test "${kmodv}" -lt 2.1.1-r3 && die "${diemsg}"
- ;;
- # 0.8.x/9999
- *)
- # We can't really cover this case realistically
- # 9999 is too hard to check and 0.8.x isn't being supported anymore.
- ;;
- esac
- fi
-
-}
-
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup