summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-05-12 22:04:15 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-05-12 22:04:15 +0200
commit5f6bb027aea09da1ec1c06d3079446a5d42247c1 (patch)
treef0b08692bdacdc6f6d37b3f11392128a8b420c3c /sci-visualization/dash
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-5f6bb027aea09da1ec1c06d3079446a5d42247c1.tar.gz
gentoo-5f6bb027aea09da1ec1c06d3079446a5d42247c1.tar.bz2
gentoo-5f6bb027aea09da1ec1c06d3079446a5d42247c1.zip
sci-visualization/dash: add dash
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-visualization/dash')
-rw-r--r--sci-visualization/dash/Manifest1
-rw-r--r--sci-visualization/dash/dash-1.20.0.ebuild51
-rw-r--r--sci-visualization/dash/metadata.xml29
3 files changed, 81 insertions, 0 deletions
diff --git a/sci-visualization/dash/Manifest b/sci-visualization/dash/Manifest
new file mode 100644
index 000000000000..6098a5f8d1a3
--- /dev/null
+++ b/sci-visualization/dash/Manifest
@@ -0,0 +1 @@
+DIST dash-1.20.0.tar.gz 1786368 BLAKE2B 2826336f72b9bea80be6ef77df49109b7b68ed93678b606c998a1906907551551a3228e1140d20c6e1b5bf5e53fb9cebd0c0a4d7ab5cc1a590e47ef351558a40 SHA512 670cf593068370c70f1db25c70c7a76ce98c696efbff1146cc90f90a99b8b48bf80cf47688504d173ef253ccb9f1170c2067b3af9414eacb226f7ef25149ffff
diff --git a/sci-visualization/dash/dash-1.20.0.ebuild b/sci-visualization/dash/dash-1.20.0.ebuild
new file mode 100644
index 000000000000..3d4344e62315
--- /dev/null
+++ b/sci-visualization/dash/dash-1.20.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/future[${PYTHON_USEDEP}]
+ sci-visualization/dash-table[${PYTHON_USEDEP}]
+ sci-visualization/dash-html-components[${PYTHON_USEDEP}]
+ sci-visualization/dash-core-components[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+src_prepare() {
+ distutils-r1_src_prepare
+ cd dash-renderer
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ distutils-r1_src_configure
+ cd dash-renderer
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ cd dash-renderer
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ cd dash-renderer
+ distutils-r1_src_install
+}
diff --git a/sci-visualization/dash/metadata.xml b/sci-visualization/dash/metadata.xml
new file mode 100644
index 000000000000..166d71c6fb59
--- /dev/null
+++ b/sci-visualization/dash/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dash is a productive Python framework for building web analytic
+ applications.
+ Written on top of Flask, Plotly.js, and React.js, Dash is ideal for
+ building data visualization apps with highly custom user interfaces in
+ pure Python. It's particularly suited for anyone who works with data in
+ Python.
+ Through a couple of simple patterns, Dash abstracts away all of the
+ technologies and protocols that are required to build an interactive
+ web-based application. Dash is simple enough that you can bind a user
+ interface around your Python code in an afternoon.
+ Dash apps are rendered in the web browser. You can deploy your apps to
+ servers and then share them through URLs. Since Dash apps are viewed in
+ the web browser, Dash is inherently cross-platform and mobile ready.
+ Dash ships with supercharged components for interactive user
+ interfaces. A core set of components, written and maintained by the
+ Dash team, is available in the dash-core-components library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">plotly/dash</remote-id>
+ </upstream>
+</pkgmetadata>