summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-09-22 10:18:26 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-09-22 10:19:13 +0200
commitae12690844146728289a3d499fa104e40fea6a5e (patch)
tree97f690b7c698284e2ec9b81db62abdd7a035cf2b /sci-mathematics
parentnet-analyzer/zabbix: dropped obsolete (diff)
downloadgentoo-ae12690844146728289a3d499fa104e40fea6a5e.tar.gz
gentoo-ae12690844146728289a3d499fa104e40fea6a5e.tar.bz2
gentoo-ae12690844146728289a3d499fa104e40fea6a5e.zip
sci-mathematics/cvc4: fix build on musl
Closes: https://bugs.gentoo.org/934053 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.8-r5.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild b/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
index 4870f7af7ba6..9bab754168e0 100644
--- a/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
@@ -57,6 +57,17 @@ src_configure() {
-DENABLE_PROOFS="$(usex proofs ON OFF)"
)
cmake_src_configure
+ # Bug #934053 - build with musl
+ antlr3 "${S}"/src/parser/cvc/Cvc.g -fo "${BUILD_DIR}"/src/parser/cvc || die
+ sed -i \
+ -e "s|k = NULL|k = 0|g" \
+ -e "s|n = NULL|n = 0|g" \
+ -e "s|k1 = NULL|k1 = 0|g" \
+ -e "s|k2 = NULL|k2 = 0|g" \
+ -e "s|lo = NULL|lo = 0|g" \
+ -e "s|hi = NULL|hi = 0|g" \
+ "${BUILD_DIR}"/src/parser/cvc/CvcParser.c \
+ die
}
src_test() {