summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-03-12 23:59:32 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-03-13 00:57:58 +0100
commit8601caeabd58a7a716b951b03c8c1655c62bd8b0 (patch)
treee9d9166f8855fdca9d17910426fff8d6312efbb4 /sci-libs
parentwww-client/qutebrowser: drop old (diff)
downloadgentoo-8601caeabd58a7a716b951b03c8c1655c62bd8b0.tar.gz
gentoo-8601caeabd58a7a716b951b03c8c1655c62bd8b0.tar.bz2
gentoo-8601caeabd58a7a716b951b03c8c1655c62bd8b0.zip
sci-libs/armadillo: Version bump 10.3.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/armadillo/Manifest1
-rw-r--r--sci-libs/armadillo/armadillo-10.3.0.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/sci-libs/armadillo/Manifest b/sci-libs/armadillo/Manifest
index 0eacdd62daba..b087495c86e3 100644
--- a/sci-libs/armadillo/Manifest
+++ b/sci-libs/armadillo/Manifest
@@ -1 +1,2 @@
DIST armadillo-10.2.0.tar.xz 6042348 BLAKE2B e85f24ca7137c3a8c8fc53db15b382f2e4d468673c99e036ef9b4a4436be47d24a37664dfa88ff9effa08a4c868bd212d03c204dda09cd26038a0f8ccbf61375 SHA512 c5d6f4bac0acba63fbd7681653d521249fd303ffbbc5b18df71500eb111514c1d09db600a580091d6a23c83748c109c30938bbcd80a3a0b2c25e2fdea932f2cd
+DIST armadillo-10.3.0.tar.xz 6214388 BLAKE2B 212d543e8d1845c974cf11302a944a151f63c7f301046910da6b2f27684080df520e5be10f8490a1cc27071ec84b1a91a2431e33960b561c56b291575bb003e8 SHA512 99877ff6581d3effea282d1c4e258883618f4107d84cfe85ed877afc62ba445793e760693c0c6c2113a1822881160cb10adb90087e97b4e31d3a1e64344a6353
diff --git a/sci-libs/armadillo/armadillo-10.3.0.ebuild b/sci-libs/armadillo/armadillo-10.3.0.ebuild
new file mode 100644
index 000000000000..baaa3579072c
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-10.3.0.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake toolchain-funcs multilib eutils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0/10"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="arpack blas doc examples hdf5 lapack mkl superlu test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( lapack )"
+
+# atlas? ( sci-libs/atlas[lapack] )
+
+RDEPEND="
+ dev-libs/boost
+ arpack? ( sci-libs/arpack )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ superlu? ( >=sci-libs/superlu-5.2 )
+"
+
+DEPEND="${RDEPEND}
+ arpack? ( virtual/pkgconfig )
+ blas? ( virtual/pkgconfig )
+ hdf5? ( sci-libs/hdf5 )
+ lapack? ( virtual/pkgconfig )
+ mkl? ( sci-libs/mkl )
+"
+PDEPEND="${RDEPEND}
+ hdf5? ( sci-libs/hdf5 )
+ mkl? ( sci-libs/mkl )
+"
+
+src_prepare() {
+ # avoid the automagic cmake macros...
+ sed -i -e 's/^ *include(ARMA_Find/# No automagic include(ARMA_Find/g' CMakeLists.txt || die
+
+ # ... except for mkl, since without a license it's hard to figure out what to do there
+ if use mkl; then
+ sed -i -e 's/^# No automagic include(ARMA_FindMKL)/include(ARMA_FindMKL)/g' CMakeLists.txt || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
+ )
+ if use arpack; then
+ mycmakeargs+=(
+ -DARPACK_FOUND=ON
+ -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
+ )
+ else
+ mycmakeargs+=(
+ -DARPACK_FOUND=OFF
+ )
+ fi
+# if use atlas; then
+# local c=atlas-cblas l=atlas-clapack
+# $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
+# $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
+# mycmakeargs+=(
+# -DCBLAS_FOUND=ON
+# -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
+# -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
+# -DCLAPACK_FOUND=ON
+# -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
+# -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
+# )
+# fi
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ )
+ else
+ mycmakeargs+=(
+ -DBLAS_FOUND=OFF
+ )
+ fi
+ if use hdf5; then
+ mycmakeargs+=(
+ -DDETECT_HDF5=ON
+ -DHDF5_LIBRARIES="-lhdf5"
+ -DHDF5_INCLUDE_DIRS=/usr/include
+ )
+ else
+ mycmakeargs+=(
+ -DDETECT_HDF5=OFF
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ else
+ mycmakeargs+=(
+ -DLAPACK_FOUND=OFF
+ )
+ fi
+ if use superlu; then
+ mycmakeargs+=(
+ -DSuperLU_FOUND=ON
+ -DSuperLU_LIBRARY="$($(tc-getPKG_CONFIG) --libs superlu)"
+ -DSuperLU_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I superlu | awk '{print $1}' | sed 's/-I//')"
+ )
+ else
+ mycmakeargs+=(
+ -DSuperLU_FOUND=OFF
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ pushd examples > /dev/null
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
+ LIB_FLAGS="-L.. -larmadillo $($(tc-getPKG_CONFIG) --libs blas lapack)"
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
+ emake clean
+ popd > /dev/null
+}
+
+src_install() {
+ cmake_src_install
+ dodoc README.md
+ use doc && dodoc *pdf *html
+ if use examples; then
+ docinto /usr/share/doc/${PF}/examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}