summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2020-12-08 13:37:32 +1300
committerMichael Orlitzky <mjo@gentoo.org>2020-12-08 23:37:15 -0500
commit058a9e3d8c4b5b025c0a34d92495327f1b4a089f (patch)
tree1db753ad2810eac242aaf61f2f76cfcb394c4e90 /sci-libs/fplll
parentdev-db/pgtap: Bump to 1.1.0 (diff)
downloadgentoo-058a9e3d8c4b5b025c0a34d92495327f1b4a089f.tar.gz
gentoo-058a9e3d8c4b5b025c0a34d92495327f1b4a089f.tar.bz2
gentoo-058a9e3d8c4b5b025c0a34d92495327f1b4a089f.zip
sci-libs/fplll: new upstream release. Enable qd.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/Manifest1
-rw-r--r--sci-libs/fplll/fplll-5.4.0.ebuild30
-rw-r--r--sci-libs/fplll/metadata.xml3
3 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index 7db55152bdea..7de415791455 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1,3 +1,4 @@
DIST fplll-5.3.2.tar.gz 1284989 BLAKE2B 66d022c1a6acb3f029c871bebf4925ec5f9447af71829c6d52f2065155bf75f075965a41918722d095546ca18e8e87a85f181a76f5e42abd20c8de8165210bab SHA512 eacd990c468b1d919e1d6cc04f99656d982d5a3807970e0a1dd910a2703eb5b8eff913bc5c0e45790a547bb7aa71189fb9022024186bb84ee04d8602c9980ac2
DIST fplll-5.3.3.tar.gz 1289510 BLAKE2B 116af9013a9c030301f2a37fae9c4865244c93de8d7a06e6f605387c4e421f9e0735c456291cb1e44d6da3c82dbea3a8f91709eea3f69a4aab1fee876f534aff SHA512 f69b98c9befe9f2ce15fdcb1b4c1bf83a7267f606770228e05416e13930d1ecb745824b1793ccc11ab13ddb0140c1daa6cfade50f2e79f93dee296880d98bef4
+DIST fplll-5.4.0.tar.gz 2612340 BLAKE2B 723230856461ac6418dad00e82fc7505dbbb7bfbbf68fa7f4f3240402d62f3e1ded3049c436a0f6aad9f020727d10acb3fe15dfb8b8a907f5b3c7b191e55e9a9 SHA512 a583aac73e4618ba240c28d3e8485cef6b9c184c11b33799404e96ab99502023073ed1c6fc0d3fbc4e6737415e9ea1a273f3f1e59ccba69d1546f56903567ebe
DIST libfplll-4.0.4.tar.gz 413519 BLAKE2B afeea5a813d3d5b1b7fe3e81d5a8e9bce66ee4f8a3d265dacaa0ba7ff2f632f0f533182027322e2fd17645f5bc5816b266b167da0e36a00a38f73e794e22a522 SHA512 81cf61118f0dadca8fd82cc58df2fb5f0dc3ddd15a9b5de95a7777e0ece77d8f6a6d50d14ba7fdd6be6697cf375fac2e60792c94cc65f5a181c427dea84d552d
diff --git a/sci-libs/fplll/fplll-5.4.0.ebuild b/sci-libs/fplll/fplll-5.4.0.ebuild
new file mode 100644
index 000000000000..1b7435af5dd4
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs qd"
+
+BDEPEND=""
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/fplll/metadata.xml b/sci-libs/fplll/metadata.xml
index 51b421021524..c35857534278 100644
--- a/sci-libs/fplll/metadata.xml
+++ b/sci-libs/fplll/metadata.xml
@@ -21,4 +21,7 @@
<upstream>
<remote-id type="github">fplll/fplll</remote-id>
</upstream>
+ <use>
+ <flag name="qd">Use <pkg>sci-libs/qd</pkg> for quad-double datatype</flag>
+ </use>
</pkgmetadata>