summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-05-24 10:59:50 +0200
committerDavid Seifert <soap@gentoo.org>2024-05-24 10:59:50 +0200
commit6da5b3550122801911fb21b58e81be7f45d6fdce (patch)
tree777e9ebf9dcbb11d77bf3ae634fcb605a8d5e59b /sci-biology
parentsci-libs/htslib: add 1.20 (diff)
downloadgentoo-6da5b3550122801911fb21b58e81be7f45d6fdce.tar.gz
gentoo-6da5b3550122801911fb21b58e81be7f45d6fdce.tar.bz2
gentoo-6da5b3550122801911fb21b58e81be7f45d6fdce.zip
sci-biology/samtools: add 1.20
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/samtools/Manifest1
-rw-r--r--sci-biology/samtools/samtools-1.20.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-biology/samtools/Manifest b/sci-biology/samtools/Manifest
index 3ff37ea64bc7..c3163dc68eeb 100644
--- a/sci-biology/samtools/Manifest
+++ b/sci-biology/samtools/Manifest
@@ -1 +1,2 @@
DIST samtools-1.19.2.tar.bz2 9150483 BLAKE2B fb845b2ccd61f1731ef4cdc180f4b9a4ac75e8c73c1ceaa9409b99e8052ca66b88c73fc71fd1067942aa24964f6df8dcb2d93631e5757e0cc200d7a3b9fad461 SHA512 c08d729fed21112855e0acc9cf7f29c7670d38a02ad6b0f2e9b9ef15a18f07e3e194cc4f6913481c98cd3e85dd4dc975dac96155b892da58bbe8ea3679a5270f
+DIST samtools-1.20.tar.bz2 9179938 BLAKE2B b534e659899a822e191c779a6ce9247854036da3435a0b63748783edc96d610ff0f02f73bbb5c1eab3ff86dbcca331113f3312a7c3376141ef89b6a8684446e4 SHA512 8526286243d057758cb846311d0a8c728026d31438e87fcc03e0df576f33bcc6da0e18bce141dbdc438a116341c94aa92701cdf10ba6b1301eadedbb34120822
diff --git a/sci-biology/samtools/samtools-1.20.ebuild b/sci-biology/samtools/samtools-1.20.ebuild
new file mode 100644
index 000000000000..42879b0f8698
--- /dev/null
+++ b/sci-biology/samtools/samtools-1.20.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-htslib=system \
+ CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw || die)"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}