summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 20:16:43 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 20:16:43 +0200
commit3824658136045784a1d0d8ff1f3d7230a912c858 (patch)
treee26b1027e8e3024aacd530711c4fd52edd74d733 /net-misc/streamlink/streamlink-1.3.1-r1.ebuild
parentnet-misc/seafile: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP (diff)
downloadgentoo-3824658136045784a1d0d8ff1f3d7230a912c858.tar.gz
gentoo-3824658136045784a1d0d8ff1f3d7230a912c858.tar.bz2
gentoo-3824658136045784a1d0d8ff1f3d7230a912c858.zip
net-misc/streamlink: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/streamlink/streamlink-1.3.1-r1.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-1.3.1-r1.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-misc/streamlink/streamlink-1.3.1-r1.ebuild b/net-misc/streamlink/streamlink-1.3.1-r1.ebuild
index bc7367b7878f..339f8b00c2ff 100644
--- a/net-misc/streamlink/streamlink-1.3.1-r1.ebuild
+++ b/net-misc/streamlink/streamlink-1.3.1-r1.ebuild
@@ -8,7 +8,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_8 )
PYTHON_REQ_USE='xml(+),threads(+)'
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -31,12 +31,12 @@ RESTRICT="!test? ( test )"
# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
DEPEND="
$(python_gen_cond_dep '
- >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
- >=dev-python/urllib3-1.23[${PYTHON_MULTI_USEDEP}]
- dev-python/isodate[${PYTHON_MULTI_USEDEP}]
- dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
- dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.23[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
')
"
RDEPEND="${DEPEND}
@@ -46,15 +46,15 @@ RDEPEND="${DEPEND}
BDEPEND="
$(python_gen_cond_dep '
doc? (
- dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
- dev-python/docutils[${PYTHON_MULTI_USEDEP}]
- dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
)
test? (
- dev-python/mock[${PYTHON_MULTI_USEDEP}]
- dev-python/requests-mock[${PYTHON_MULTI_USEDEP}]
- dev-python/pytest[${PYTHON_MULTI_USEDEP}]
- dev-python/freezegun[${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
)
')"